[Rust plugin] Struct indentation does not work properly

When I define new struct, after writing the first field, the caret does not move to the next line with the same indentation

 

What I expect:

struct Foo

{

    bar: i32,

    |   

}

 

What Im getting:

struct Foo

{

    bar: i32,

|   

}

1

You can try enabling the (Settings/Preferences | Editor | Code Style | Language | Use tab character) checkbox. If the setting doesn't work for your file, try to reformat the code.

Pay by Plate Ma

As another option, you can move the caret using shortcuts (Ctrl/Cmd | Right/Left arrow).

0

Hey there! I faced a similar issue before. Have you checked your code style settings? Sometimes adjusting the settings or reformatting the code helps. If that doesn't work, manually moving the caret using shortcuts might be a quick fix. Let me know if you find a solution! 

0

请先登录再写评论。