Linux focus/blur hangs for 4-8 seconds


Every time I focus on or away from the editor in IDEA Ultimate, it freezes the cursor, scroll, and clipboard.


  • Click on the editor after focusing on any other program and scroll.  Scrolling doesn't start for 4-8 seconds.
  • Click on the editor, highlight some text, copy, click on a lightweight editor and attempt to paste.  The paste buffer takes 4-8 seconds to appear in the editor.


2022-09-21 11:02:50,797 [  65105]   INFO - #c.i.c.ComponentStoreImpl - Saving Project(name=****, containerState=COMPONENT_CREATED, componentStore=/home/****/projects/****)RunManager took 3959 ms
2022-09-21 11:02:50,798 [  65106]   INFO - #c.i.o.c.i.s.StoreUtil - saveProjectsAndApp took 4093 ms


"BaseDataReader: error stream of fsnotifier" prio=0 tid=0x0 nid=0x0 runnable
     java.lang.Thread.State: RUNNABLE
 (in native)
"java" prio=0 tid=0x0 nid=0x0 waiting on condition
   java.lang.Thread.State: WAITING

I've tried:

  • Updating IDEA to 2022.2.2
  • Disabling plugins
  • Increasing memory IDEA requests at startup
  • Deleting .cache and .idea directories, only restoring workspace.xml

I'm using Debian Linux with 64GB of memory, SSD, X11, with an AMD Ryzen 7 4800H with 16 cores, 64-bit

评论操作 固定链接

Thank you so much for the help.

Disabling the downloaded plugins didn't help, but completely recreating the project .idea directory did.  I then went to restore my tomcat config in workspace.xml when I discovered that the file had a lot of repeated entries from the "Tomcat (Smart)" plugin.  Disabling the plugin wasn't enough.  I had to ensure the entries were removed.  It trimmed the file down considerably.

The 5 same predefined_log_file entities were repeated in the xml:

     <configuration name="Flexline (Smart)" type="com.poratu.idea.plugins.tomcat" factoryName="SMART_TOMCAT_FACTORY">
       <predefined_log_file enabled="true" id="Tomcat Localhost Log" />
       <predefined_log_file enabled="true" id="Tomcat Access Log" />
       <predefined_log_file id="Tomcat Catalina Log" />
       <predefined_log_file id="Tomcat Manager Log" />
       <predefined_log_file id="Tomcat Host Manager Log" />

When I grepped the file to see how many there were, grep reported 1,310,724 (I'm not sure why that isn't divisible by 5).

I have submitted a issue to the 3rd party plugin developer at

Thanks again!

评论操作 固定链接

Hi Steven,

What kind of project do you have? What frameworks are used?

Do you see the same behavior in a simple new Java project?

Please provide the resulting archive of the Help | Collect Logs and Diagnostic Data operation. You can upload it privately to and provide the upload id.

评论操作 固定链接

This is a Kotlin project with no frameworks, just tomcat and using exposed to access a database.

I tried opening a new Java project, and didn't see any performance issues while in that project and changing focus.

评论操作 固定链接

Does it make a difference if you temporarily disable Kotlin plugin in your original project and try to reproduce the issue?

Please provide the logs for further analysis.

评论操作 固定链接

Upload ID: 2022_09_23_2AiXU29QiYQyRFYjd2nL7B

评论操作 固定链接

I tried disabling the Kotlin plugin (which also disabled Android, Design Tools, and Ktor plugins), and I still see the issues.

评论操作 固定链接

Thank you.

Does it help if you:

  • Disable all downloaded plugins (SonarLint, GitToolBox, Smart Tomcat) Settings | Plugins | ⚙ | Disable all downloaded plugins
  • Close the project, remove (or rename/move aside) the entire .idea directory and any .iml files from the project's root
  • Restart IDEA

Some stack traces in the logs point to I/O issues. Make sure that all IDE default directories, as well as IDE installation and project directories have sufficient read/write permissions, and are excluded from the Antivirus/firewall scan (help articles one and two).

评论操作 固定链接

Happy to help Steven. Great job id'ing the offending bit of data👍