Plugin verification failing due to wrong class file version in openapi classes

已回答

The latest plugin verification is failing every one of our plugin classes. It seems openapi classes were compiled under Java 17 and the verification system is not expecting or unable to handle this.

For example: "Unable to read class 'com/intellij/openapi/actionSystem/AnAction' using the ASM Java Bytecode engineering library. The internal ASM error: IllegalArgumentException: Unsupported class file major version 61."

评论操作 固定链接

This is for IntelliJ IDEA Ultimate IU-223.4884.69 (2022.3 (eap))

0
评论操作 固定链接

Thank you for reporting, Larry.
Please watch the following issue for more details:
https://youtrack.jetbrains.com/issue/MP-4807

0

请先登录再写评论。