Marketplace Plugins are not loaded

已回答
 at [Source: (sun.net.www.protocol.http.HttpURLConnection$HttpInputStream); line: 1, column: 2]'). Please check your network settings.
2022-09-26 10:53:38,430 [3501860]   INFO - #c.i.i.p.PluginManagerConfigurable - Main plugin repository is not available ('Unexpected character ('<' (code 60)): expected a valid value (JSON String, Number, Array, Object or token 'null', 'true' or 'false')
 at [Source: (sun.net.www.protocol.http.HttpURLConnection$HttpInputStream); line: 1, column: 2]'). Please check your network settings.
2022-09-26 10:53:39,223 [3502653]   INFO - #c.i.i.p.PluginManagerConfigurable - Main plugin repository is not available ('Unexpected character ('<' (code 60)): expected a valid value (JSON String, Number, Array, Object or token 'null', 'true' or 'false')
 at [Source: (sun.net.www.protocol.http.HttpURLConnection$HttpInputStream); line: 1, column: 2]'). Please check your network settings.
2022-09-26 10:53:42,098 [3505528]   INFO - #c.i.i.p.m.MarketplaceRequests - Error reading Marketplace file: com.fasterxml.jackson.core.JsonParseException: Unexpected character ('<' (code 60)): expected a valid value (JSON String, Number, Array, Object or token 'null', 'true' or 'false')
 at [Source: (sun.nio.ch.ChannelInputStream); line: 1, column: 2] (file=C:\Users\kapila.shantha\AppData\Local\JetBrains\IdeaIC2022.2\plugins\pluginsXMLIds.json URL=https://plugins.jetbrains.com/files/pluginsXMLIds.json)
2022-09-26 10:53:42,098 [3505528]   INFO - #c.i.i.p.m.MarketplaceRequests - Cannot get plugins from Marketplace: Unexpected character ('<' (code 60)): expected a valid value (JSON String, Number, Array, Object or token 'null', 'true' or 'false')
 at [Source: (sun.nio.ch.ChannelInputStream); line: 1, column: 2]
评论操作 固定链接

Could you share the entire IDE logs folder after restarting and reproducing the problem? (Help | Collect Logs and Diagnostic Data)

Also, please clarify the exact steps to reproduce the issue.

The files can be uploaded at https://uploads.jetbrains.com (do not forget to specify the UploadID)

Thank you!

0
评论操作 固定链接

Uploaded 

ID - 2022_09_27_RbB3iU466XSLcrcR3UvgEe

0
评论操作 固定链接

Thank you!

It looks like something went wrong during the XML parsing. Please upload your file C:\Users\***\AppData\Local\JetBrains\IdeaIC2022.2\plugins\pluginsXMLIds.json at https://uploads.jetbrains.com.

Can you download pluginsXMLIds.json from web browser without problems? (https://plugins.jetbrains.com/files/pluginsXMLIds.json)

Do you have antivirus/firewall configured?

If you're behind a corporate proxy make sure it is properly configured in the IDE - https://www.jetbrains.com/help/idea/settings-http-proxy.html 

0
评论操作 固定链接

Thanks it's working fine now

0
评论操作 固定链接

I'm now using Fedora36 on VM.  The same issue is there for linux. I try the replace the new json file but the issue is not fixing 

 

Upload id: 2022_10_21_cdmWvvYHEKAjg9E52U5rsq (file: idea.log)

0
评论操作 固定链接

Kapilashantha Does it help if you disable the Kotlin plugin and restart the IDE?

0
评论操作 固定链接

I just check by disabling Kolin plugin but still same the issue 

0
评论操作 固定链接

Please add the following lines to Help | Diagnostic Tools | Debug Log Settings:

com.intellij.util.io.HttpRequests
#com.intellij.util.io.HttpRequests
com.intellij.util.proxy.CommonProxy
#com.intellij.util.proxy.CommonProxy

Restart the IDE, then reproduce the issue and upload the idea.log once again.

0
评论操作 固定链接

Attached log

Upload id: 2022_10_22_VZMBvcat9fZzfnV9SbwGJT (file: debug.log)

0
评论操作 固定链接
Looks like the same here: https://intellij-support.jetbrains.com/hc/en-us/community/posts/7803445867154-Marketplace-Plugins-are-not-loaded/comments/7824514645266

Please upload your file `home/paynet-kapila/.cache/JetBrains/IdeaIC2022.2/plugins/pluginsXMLIds.json` at https://uploads.jetbrains.com.

Can you download pluginsXMLIds.json from web browser without problems? (https://plugins.jetbrains.com/files/pluginsXMLIds.json)

Do you have antivirus/firewall configured?

If you're behind a corporate proxy make sure it is properly configured in the IDE - https://www.jetbrains.com/help/idea/settings-http-proxy.html

0
评论操作 固定链接

 

I'm using VMware tool on windows 11 (windows has configured the corporate proxy for accessing the internet).  However, it's still failing when I'm using hotspot from my mobile (disable the proxy setting in windows) 

But it's still confusing me why I can't access the URL https://plugins.jetbrains.com/files/pluginsXMLIds.json even I'm connecting from mobile hotspot 

 

Upload id: 2022_10_25_5qBJoEVBBNbutfi11cJnHT (file: idea_conf.zip)

0
评论操作 固定链接
Can you access the Internet from your VM? Do you have the VMWare Network Adapter(VMnet8) configured?
https://docs.vmware.com/en/VMware-Workstation-Pro/16.0/com.vmware.ws.using.doc/GUID-89311E3D-CCA9-4ECC-AF5C-C52BE6A89A95.html

Also, it seems that `No proxy` is configured in the IDE. Please try to configure the same as the windows proxy in the IDE.
0
评论操作 固定链接

Yes can access internet from VM. 

For my testing, I have disabled the proxy and use my private WiFi.  

0
评论操作 固定链接

What do you see if you open the developer tool?

0
评论操作 固定链接

What about clicking the `Not secure` on the browser? Do you have this root certification imported?

0
评论操作 固定链接

I think it's not the issue because DigiCert already in list


0
评论操作 固定链接
I reported this issue. Feel free to watch the YouTrack item in order to be notified once it has updates. See [this article](https://intellij-support.jetbrains.com/hc/articles/207241135) if you are not familiar with YouTrack.
https://youtrack.jetbrains.com/issue/IDEA-304636/
0

请先登录再写评论。