How to disable coverage project view pop-up pane/window

Every time I execute a (Typescript project) run configuration with coverage, a pane pops up using half of my screen: it's not the coverage report, but instead looks just like the Project Files view, and seems to be entirely useless, existing only to force you to drag your mouse over and close it.  Is there any way to disable this pop-up?  Its title is "Coverage:" and the name of the run configuration; it's tied to "Coverage" in the right gutter.

The best I've been able to do to get rid of it is drag it over to the same gutter as the Project Files pane and shrink it down to the same size as that, so it at least doesn't consume half my editing space..

评论操作 固定链接

Hi there,

This one? https://www.jetbrains.com/help/webstorm/coverage-tool-window.html

If it is then it actually shows the coverage.

2
评论操作 固定链接

Interesting.  Same window alright but the Statistics column is empty, even when I expand all the way down to the file I'm running tests & coverage on.  The coverage markup in the source editor and the coverage report in the console seem much more useful.

That said, even if it did show something useful I'd prefer it not to pop up so aggressively while I'm focused on testing one source file.  Is that doable?

0
评论操作 固定链接

Same window alright but the Statistics column is empty, even when I expand all the way down to the file I'm running tests & coverage on.

Works for me. Must be your coverage configuration (not gathering this info?) or it does not report what files are covered correctly (sorry, not JavaScript/TypeScript person, cannot help much on this part). An example for running PHPUnit test with coverage (in my IDE test project).

 

That said, even if it did show something useful I'd prefer it not to pop up so aggressively while I'm focused on testing one source file.  Is that doable?

That should do:

0
评论操作 固定链接

Yeah I thought that would be the thing to control it: tried it already, and it didn't work.  Weird.  Must be something wrong with my config as you say.  Will maybe try a reinstall.

Thanks very much for your time Andriy.

0
评论操作 固定链接

Yeah I thought that would be the thing to control it: tried it already, and it didn't work.

The option on the 2nd screenshot? It definitely works for me when running PHPUnit test with Coverage.

NOTE: I'm using PhpStorm 2022.2.2 but this should make no difference as it's a platform-wide functionality... But then, I've checked WebStorm Issue Tracker and found this one...: https://youtrack.jetbrains.com/issue/WEB-51989

 

Regarding not having the coverage info: could it be your case as well (it does not really have much details though, unless there are private attachments that only devs can see)? https://youtrack.jetbrains.com/issue/WEB-51976

 

I'm sure someone from WebStorm Support Team will see and reply here soon (AFAIK they are checking forums on a daily basis).

0
评论操作 固定链接

I just tried to produce a stripped-down example of the unwanted pop-up but failed: when "Activate Coverage View" is off, the coverage window now does not pop up any more; some modules got updates yesterday and I restarted IJ because of low memory complaints, so it may just have been a transient.  All good now anyway; thanks again for your help.

1

请先登录再写评论。