Editor Preferences: Bold Text

已回答

Hi!

I have edited colour scheme and fonts in PS. Changed to JetBrains Mono.

Problem is: The default text seems bold and config says it is not.

Have a look at the white text. It is bold or semibold.

Menlo seems to have the same issue, but with Monaco font the default text looks "regular".

In Preferences "Main weight" is set to "Regular". And "Editor > Color Scheme > General > Text > Default text" is not marked as "Bold". When I change "Main weight" to thin, there is still a gap between default and other text. And changing "Bold weight" to thin it effects exactly the white text. So, PS is using bold font there.

Any ideas? 

0

1) Please check if switching to one of the default color schemes (e.g. Darcula) fixes the issue. Would like to check if the problem is in the scheme or not.

 

2) What OS & IDE version are you running?

0

Thanks for your assistance!

1) Switched to Dracula and font looks regular, not bold.

2) macOS with PhpStorm 2022.2 (Build #PS-222.3345.135, built on July 28, 2022)

My color scheme is a slightly adjusted Monokai. IIRC I just edited some colors, nothing special and font change is only done on "Editor > Font".

0

Thanks, found it. That's XML > Tag Data, under Editor > Color Scheme settings. Looks like most of the dark themes have "Bold" option selected by default there.

Simply untick this option.

1

Great, that's it! :-) Many thanks!

Have set it to inherit values from "Text->Default text"

0

请先登录再写评论。