Can't set default path for project to open in browser

I've got Apache, PHP, and MySQL (MariaDB) running on Windows, with Apache and PHP working properly.

However, in PHPStorm I can't figure out how to get it to recognize the location of my project when trying to preview a page in a browser.

My project sits at: C:\Misc\Dev\PHP\projects\lpmj6 (top left). 

Bottom right, you can see the alias I have setup in Apache to the same path, so if I go to that patch and open ch1.php it works fine.

However, when I preview the page in a browser, it's not going to the correct path.

This setup is an import of my settings from another older PC. I remember when setting up that machine, PHPStorm magically identified where my Apache setup was, MySQL, PHP, etc. Is there a way to get it go through that process again? I'm wondering if there's something incorrectly copied over that's causing this problem.

 

评论操作 固定链接

I figured it out!

Under Settings | Build, Execution, Deployment | Deployment, I was able to setup the web path to be executed for that project.

0

请先登录再写评论。