PHPStorm Javascript Debug Chrome Profile

As similar issue to Chrome custom user profile for javascript debugging? which seems to have no solution. It refers to a Chrome extension being installed only on the Profile required for Javascript debugging, however I beleive this has now been deprecated.

I simply wish to launch Javascript Debug in a defined Chrome Profile where caching is switched off.

Currently it seems to launch a random profile and I have to open Dev Tools and disable caching - EACH TIME.

 

评论操作 固定链接

Additionally now, having downloaded and created a new debug profile to use Firefox (because simply switching the existing one to Firefox) has no effect.

Everything opens in a random version of Chrome.

0
评论操作 固定链接

>I simply wish to launch Javascript Debug in a defined Chrome Profile where caching is switched off. Currently it seems to launch a random profile and I have to open Dev Tools and disable caching - EACH TIME.

the IDE needs to pass --remote-debugging-port option to Chrome in order to attach a debugger; there is no way to pass this option to a running instance, so the browser is started with new fresh profile to ensure that no instances using the same user data are running. You can set up Chrome to run with your user data, but, if you do this, you need to make sure that no instances that use this data are open when you start the debugger

>Additionally now, having downloaded and created a new debug profile to use Firefox (because simply switching the existing one to Firefox) has no effect. Everything opens in a random version of Chrome

Debugging is only supported in Chrome and browsers of the Chrome family, as it's stated in Help. So, when you start the app with the run/debug configuration, the IDE will try to open Chrome (or, if it can't be found in the browsers list in Preferences | Tools | Web Browsers and Preview, the first listed Chromium-based browser will be used) .

We used to support Firefox remote debugging (but without source maps) through the FireFox Remote run configuration, but our solution doesn't work in the latest Firefox versions due to changes in the protocol, and there doesn't seem to be an easy way to fix it, so the configuration has been removed in the recent updates.

If you don't need to debug your application and just like to preview your page in FireFox, try using the browser bar in editor upper right corner to open the page in the browser of your choice

0
评论操作 固定链接

You have given info for Webstorm, not PHPStorm. I have tried from scratch to set this up on a development machine. it is still opening a random Chrome and ignores any settings.

Opening chrome://version in the window PHPStorm opens:

My Phpstorm settings:

0
评论操作 固定链接

>you have given info for Webstorm, not PHPStorm.

instructions are equal for both IDEs, it's the same functionality

> it is still opening a random Chrome and ignores any settings

sorry, but the profile path: from chrome://version matches the user data path you have specified in PhpStorm settings, doesn't it?

0
评论操作 固定链接

yes, what I am trying to say is that I have specified Profile 3, however Phpstorm opens in this case 'default' as evidenced by chrome://verson

0
评论操作 固定链接

and this issue again (as said on a new machine)

however in browser the file is clearly accessable

0
评论操作 固定链接

>yes, what I am trying to say is that I have specified Profile 3, however Phpstorm opens in this case 'default' as evidenced by chrome://verson

where did you specify the profile 3? I can only see a path to user data. To pass a non-default profile, try adding --profile-directory="Profile 3" option to Command line options: field

0
评论操作 固定链接

Can you please specify this step by step

To recap:

I wish PHPStorm to open the development profile (here profile 3). I suspect at least 3 Chrome profiles for the above scenario is not unusual, however its likely we might need more developer profiles for different customers we are working on.

  • So Profile 3 should be an example of a developer profile
  • PHPStorm should always open that profile when clicking Debug
  • The opened profile can be identified with chrome://version
  •  
  • Please advise where ALL the above errors are coming from.
-1
评论操作 固定链接

You have to specify the Chrome user data directory as you did:

and add -profile-directory="Profile 3" option to Command line options: field

1
评论操作 固定链接

Thanks, this seems to have progressed to opening the same profile each time, however it does not keep the 'disable cache' setting for network in the developer tools, is there anyway of fixing this

0

请先登录再写评论。