SSL verification problems when using copilot


I am using Github copilot in intellij idea 2021.3.3. When copilot makes calls to http:// it returns the following error: "Request Error: unable to verify the first certificate". I have imported the entire certificate chain for this website into Settings/Tools/Server Certificates dialog, and I have even imported into the keystore.of the jre being used to run intellij (Jetbains/<intellij version>/jbr/lib/security/cacerts. I have also tried downloading each certificate in the chain and importing each one using the Server Certificates dialog. 

I have tried calling the same url using openssl and trusting the certificate chain using command line options and the call is successful, so it is an intellij issue not something to do with the proxy (there is one - I have setup proxy authentication details under Setting/Appearance and Behaviour/System Setting/HTTP proxy and check connection using the copilot url is successful).

Can anyone help?

Thanks very much,

Steve Gray


I got the same problem and have high expectations to find a solution to use Copilot in IntelliJ IDEA


I have the same problem, did you find any solution ?

It worked for almost 6 months and “suddenly”, i got the same error “unable to verify the first certificate”.

i'm behind a company proxy too.

Versions : 
- copilot :
- intellij : 2023.3.4


Any support for this error, i use ubuntu with the lstest versions of pycharms & copilot. My company use self sign certificate.

On windows its works but on ubuntu not.

Please help