Something wiped out my Run/Debug configurations

I ran an installer for an unrelated product yesterday and now my Run/Debug configurations have all vanished.

My ~/.idea folder is missing.

How can I recover them?  I re-installed PyCharm from the installer today, no help. I tried File->Repair IDE, went through all the options, also no help.

Notice how all the Conda configurators are gone? 

How can I get them back?

 

Decided to completely erase all pycharms from my machine. I deleted the Pycharm app (moved to trash) then deleted everything under:

~/Library/Application\ Support/JetBrains/

~/Library/Caches/JetBrains/

Then I restarted the machine and ran the installer for PyCharm community again.

Now I can see Conda Environment is an option and I added the conda executable, however I still can't get a Conda Run/Debug  configuration for any python file I want to debug

Another clue is that all the available package options have disappeared

How can I restore PyCharm to it's ordinary healthy state?

 

Please help

评论操作 固定链接

I got around this by right clicking within the file I want to run and choosing Modify Run Configuration. Then I am able to modify the config. So weird, I don't know what nuked my Pycharm functionality in this way

 

Still I am unable to add a new Conda environment from Run/Debug configs

0
评论操作 固定链接

There's no conda run/debug configuration. You should add the Python run/debug configuration and make sure it has a conda interpreter selected.

0
评论操作 固定链接

That's not true. There was a Conda option which is now gone. Along with a Poetry option which is also suddenly gone

0
评论操作 固定链接

You can select the environment type (Virtualenv/Conda/Poetry/Pipenv) when creating the interpreter. When configuring run/debug configuration, however, there's only "Python", which can use any of the above environments depending on the selected interpreter.

0

请先登录再写评论。