Unable to connect to GitHiub after latest update

Hi All,

After the latest update (info pasted below) my authentication is failing for GitHub.

I have tried to re-connect to github unsuccessfully and I get the following message:

 

DataGrip 2022.3
Build #DB-223.7571.180, built on November 30, 2022
Subscription is active until October 13, 2023.
Runtime version: 17.0.5+1-b653.14 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
Windows 10 10.0
GC: G1 Young Generation, G1 Old Generation
Memory: 16384M
Cores: 20
Non-Bundled Plugins:
    bundled-datagrip-help (223.7571.208)
    org.intellij.plugins.markdown (223.7571.125)
    org.jetbrains.plugins.github (223.7571.125)

评论操作 固定链接

Could you share the log after the attempt? Help | Collect Logs and Diagnostic Data

You can upload them via https://uploads.jetbrains.com/ and share the ID here

0
评论操作 固定链接

Hi Konstantin,

I have uploaded the logs.

Upload id: 2022_12_04_3g3FkF7JLowYhy8yR4wafg (file: datagrip-logs-20221205-07502316335662616944073585.zip)

Thank you,

Mike

0
评论操作 固定链接

As a workaround, please authenticate to GitHub using Personal Access Token.

 

0
评论操作 固定链接

Hi Dimitry,

The workaround using the personal access token worked.

Could you please let me know if fixing the GitHub access is planned?

Thank you,

Mike

0
评论操作 固定链接

Login via GitHub basically should work - and appears to be working fine at the moment (checked on my machine, and ask several colleagues)

According to the team, there was some specific issue, as for some reason GitHub did not respond with the expected token.

Does it still fail for you? 

0
评论操作 固定链接

Hi Dimitry,

I still have the same issue. I still can't connect when using my account login.

I am able to log in with Git, however I still can't get my accont to work. Token works perfectly.

I have uploaded the logs again just in case there is something in there that will help.

Upload id: 2022_12_11_KdAtwS47SN2bAus1YWPj9X (file: datagrip-logs-20221212-09240310308056158063651481.zip)

0
评论操作 固定链接

Could you please check if it still works on the previous version 2022.2?

0
评论操作 固定链接

Hi Dimitry,

Could you please tell me how I can go back to an earlier version of DataGrip?

I'll be able to test this possibly next week when my workload lightens up a little.

Thank you very much,

Mike

0
评论操作 固定链接

There are several ways.

You could just download an older version from the web-site, however I would suggest using the JetBrains Toolbox App to manage installations and projects.

Thank you

0

请先登录再写评论。