How to disable single-click "open file" from Project view

Hi, I don't recall if this happened before I installed v2022.3, but this is undesired because I want to be able to limit my number of open tabs.

Basically what's happening is that it seems to act like "Open files with single click" (except I've got that disabled in the Project View). When I click through files, a new tab appears with an italicized filename in the tab title.

I've tried searching in the forums, and I want to disable this behavior. The only time the file should open on click is if I double-click it.

How do I disable this? Thanks in advance.

4

try disabling the Preferences | Editor | General | Editor Tabs | Opening policy | Enable preview tabs - does it help?
Related ticket: https://youtrack.jetbrains.com/issue/IDEA-295624/Enable-preview-tab-hard-to-distinguish-from-Open-Files-With-A-Single-Click-menu-option

12

yep that did it for me thank you. A recent update must have made this default as its only been on for one machine for me for about 3 weeks and another just today.

0

Having to disable so many new "default" settings lately, such a waste of time.

2

Disabling of `Enable Preview Tabs` didn't help. I think something went wrong with 2023.2.5

0

Please disable all non-bundled plugins and restart IDE. If it still does not solve the issue, please write to support@jetbrains.com with your screen capture.

0

请先登录再写评论。