PluginVerifier doesnt find package



I get the following error when upload a plugin:

Package 'feign' is not found along with its 5 classes.

I added the dependencies via gradle:

dependencies {
implementation 'io.github.openfeign:feign-core:12.1'
implementation 'io.github.openfeign:feign-okhttp:12.1'
implementation 'io.github.openfeign:feign-jackson:12.1'

Is there anything missing?

When trying the plugin via runIde gradle task, it works as expected


I created this gradle task to copy the jars over:

task copyDependencies {
doLast {
sourceSets.main.runtimeClasspath.each { file ->
if (file.toString().endsWith(".jar")) {
copy {
from file
into 'build/lib/'

 But this is not working. The resulting plugin.jar is still not containing the dependencies when i execute the "buildPlugin" gradle task.

I tried different "lib" folder locations aswell:

* rootFolder/lib/

* rootFolder/build/lib/



There is no need to do anything in the build file for dependencies defined with implementation scope in the plugin’s main build file. Please share your full project.


Maybe this wasnt clear, but i want to upload my plugin to the intellij market place.

When i upload it, the plugin verifier is telling me that "feign" package is missing. My plugin got rejected by an JetBrains employee because of that. So now iam trying to get the plugin verifier to accept my plugin.

Here is what iam doing now (after reading the docs posted earlier):

1. copy all external dependency jars into build/libs/ folder

2. execute "buildPlugin" gradle task

3. go into /build/libs folder and upload the plugin-name.jar file to the intellij plugin store

4. wait for the results, and the plugin verifier is still showing me that the feign package is missing.

So what should i do to make this work?

EDIT: my repo is here:

EDIT: i did a big mistake here. instead of going to /build/libs i have to go to /build/distributions and get the zipfile from there. Then it includes all the dependencies