Hide external libraries node from project view?


It's always annoying that the "external libraries" node in the project view will be expanded when a decompiled class is shown which results in a large amount of scrolling back to the interesting source. Also sometimes i accidentially expand the node. Is there any option to hide the node in the treeview?

评论操作 固定链接

Hi! Switch to Packages or Project Files view to exclude External Libraries from the tree:

In the Packages view, you can also toggle Show Libraries Contents option:

This option is available only in the Packages view. (In the Project view, libraries are always shown; in the scope views, libraries are never shown.)

Turn this option on or off to show or hide libraries and their contents.

Note that within the Libraries category are the libraries included in module dependencies and also the SDKs associated with your modules.

More info here: https://www.jetbrains.com/help/idea/project-tool-window.html#title_bar_context_menu

Also you might have a try with: https://www.jetbrains.com/help/idea/settings-scopes.html

BTW, There is a known issue about requesting this feature, please feel free to vote: https://youtrack.jetbrains.com/issue/IDEA-156848/Hide-External-Libraries-in-Project-view

Feel free to watch the YouTrack item in order to be notified once it has updates. See this article if you are not familiar with YouTrack.

评论操作 固定链接

Hi Jacky,

thank you for the explanation. Why can't i hide the "External Libraries" node in the project view, but in the other views? This is the main view i'm working with.

Best Regards


评论操作 固定链接

I don't know the reason, may by design, in the issue https://youtrack.jetbrains.com/issue/IDEA-156848/Hide-External-Libraries-in-Project-view, this behavior has already been there for seven years.