Could not start SpringBoot app

已回答

After installing IntelliJ 2023.1 EAP 3 ic couldn't start my SpringBoot app via the services panel anymore. Following exception is thrown:

Internal error (java.lang.IllegalStateException): Duplicate key NewModuleRootManager (attempted merging values [Element: <component/>] and [Element: <component/>])
java.lang.IllegalStateException: Duplicate key NewModuleRootManager (attempted merging values [Element: <component/>] and [Element: <component/>])
    at java.base/java.util.stream.Collectors.duplicateKeyException(Collectors.java:135)
    at java.base/java.util.stream.Collectors.lambda$uniqKeysMapAccumulator$1(Collectors.java:182)
    at java.base/java.util.stream.ReduceOps$3ReducingSink.accept(ReduceOps.java:169)
    at java.base/java.util.Iterator.forEachRemaining(Iterator.java:133)
    at java.base/java.util.Spliterators$IteratorSpliterator.forEachRemaining(Spliterators.java:1845)
    at java.base/java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:509)
    at java.base/java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:499)
    at java.base/java.util.stream.ReduceOps$ReduceOp.evaluateSequential(ReduceOps.java:921)
    at java.base/java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234)
    at java.base/java.util.stream.ReferencePipeline.collect(ReferencePipeline.java:682)
    at org.jetbrains.jps.model.serialization.JpsProjectLoader.lambda$loadModules$4(JpsProjectLoader.java:405)
    at java.base/java.util.concurrent.CompletableFuture$AsyncSupply.run(CompletableFuture.java:1768)
    at com.intellij.util.concurrency.BoundedTaskExecutor.doRun(BoundedTaskExecutor.java:248)
    at com.intellij.util.concurrency.BoundedTaskExecutor.access$200(BoundedTaskExecutor.java:28)
    at com.intellij.util.concurrency.BoundedTaskExecutor$1.executeFirstTaskAndHelpQueue(BoundedTaskExecutor.java:221)
    at com.intellij.util.ConcurrencyUtil.runUnderThreadName(ConcurrencyUtil.java:227)
    at com.intellij.util.concurrency.BoundedTaskExecutor$1.run(BoundedTaskExecutor.java:210)
    at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1136)
    at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:635)
    at java.base/java.lang.Thread.run(Thread.java:833)

Kind Regards

Andreas

0

Just fixed it by myself. Uninstalled IntelliJ EAP, reinstalled IntelliJ 2022.3 and then installed EAP again (all with the Toolbox app).

0

Today after starting the IDE and switched to another branch inside the IDE the error occurs again.

0

Is it possible to share idea.log ("Help | Show log in...") after restarting IDE and reproducing the issue?

0

Currently it's working again. I will upload the log, the next time the error occurs.

0

Finally i found the reason why the error occurs. When loading my project, IntelliJ notifies me, that it has detected a web framework and suggests me to configure it. If i do this, my project configuration contains 2 web profiles "Web"and "Web2". The first one hasn't any deployment descriptor (don't ask me why, i didn't created the project), but the second (generated by IntelliJ) has one. I deleted the "Web" configuration without deployment descriptor but it has no effect (even after restering the IDE). Next I deleted the deploymment descriptor from the "Web2" configuration also with no effect. Then I loaded the project in IntelliJ 2022.3.2. There i could start the project successfully. Then I loaded the project in IntelliJ EAP again (meanwhile I installed EAP 4) and now the project starts also in the EAP again.

I have uploaded the logs with following request: https://intellij-support.jetbrains.com/hc/en-us/requests/4754912

0

Thanks for information! We'll check logs.

0

请先登录再写评论。