Can't type brackets in the terminal

Completed

I asked this question quite a while ago, and it's still there and as annoying as it can get. Is there any way to solve this?

How can we PyCharm users receive proper support? It seems this support forum is completely ignored.

12 comments
Comment actions Permalink

What kind of issue are you having exactly? Typing brackets in the terminal or console within PyCharm appears to work just fine for me. More details of exactly what you're attempting to do, what you're expecting, and how that differs from what you're actually seeing would help.

0
Comment actions Permalink

Simply the brackets won't show up, I can only copy paste them, but cannot type them. Obviously this did not happen before. This only happens in the terminal, while the console works just fine.

Using a Spanish keyboard layout.

1
Comment actions Permalink

I am going to assume this was not addressed by PyCharm because the problem is probably OS based, as it only occurs in the OS terminal. If you are pressing the "Alt Gr" key (the right Alt key) I don't know why it would not show up, especially if it works in a text editor or word processor, other than the OS does not see the key combination as allowed. If you are using a Windows system try Ctrl + Alt + [ instead of AltGr + [. That seems to be the simplest of the two solutions to your problem.

From Microsoft:

To work around this problem, use one of the following methods:
-Use the CTRL + ALT keyboard shortcut instead of the ALT GR key to type extended characters in the Terminal Services session.
-Configure Windows to stop applying keyboard shortcuts to Terminal Services sessions. To do this, follow these steps:
     Click Start, click Run, type mstsc.exe, and then click OK.
     In the Remote Desktop Connection dialog box, click Options, and then click the Local resources tab.
     In the Apply Windows key combinations list, click On the local computer.
     On the General tab, click Save As, type a name in the File name box, and then click Save.

0
Comment actions Permalink

The problem was not the OS's but PyCharm's because the last patch fixed the issue.

0
Comment actions Permalink

Hi,

I am having similar problem. Every time I type option + NUM keys in MacOS within Pycharm, the command prompt changes to (arg: NUM) instead of typing desired key.

I do not have any issue in the MacOS terminal and I was able to type these keys in Pycharm's terminal before.

My Pycharm version is:

PyCharm 2021.2 EAP (Professional Edition)
Build #PY-212.3724.23, built on June 4, 2021
PyCharm EAP User
Expiration date: July 4, 2021
Runtime version: 11.0.11+9-b1481.1 x86_64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
macOS 11.4
GC: ParNew, ConcurrentMarkSweep
Memory: 4933M
Cores: 8
Non-Bundled Plugins: com.firsttimeinforever.intellij.pdf.viewer.intellij-pdf-viewer (0.11.1), com.intellij.plugins.macoskeymap (211.6432.7)

 

Thanks.

 

0
Comment actions Permalink

Joao Dias

Is it reproducible only in the 2021.2 EAP build?

0
Comment actions Permalink

Hi,

It happened suddenly while I using the terminal in Pycharm. I have not done any updates. It seems that I applied a keyboard shortcut by mistake and now I am not able to restore the settings.

0
Comment actions Permalink

You mentioned that it was working fine before. Do you mean before switching to 2021.2 EAP or something else?
Check if File | Manage IDE Settings | Restore Default Settings... helps.

0
Comment actions Permalink

With the same PyCharm version, yes!

0
Comment actions Permalink

Having the exact same issue with rubymine 2021.2

0
Comment actions Permalink

After some digging, I was able to find from the same issue of IntelliJ that this is caused by "Use Option as Meta key" in "Preferences | Tools | Terminal" on Macs.

0
Comment actions Permalink

Great! I can confirm that it has resolved the issue. Thank you.

 

0

Please sign in to leave a comment.