Process finished with exit code -1073740791 (0xC0000409) JavaFX Application

Answered

I can't find anything on internet related to my problem. So I am posting here in hope to get some help...

The following code gives the error message "Process finished with exit code -1073740791 (0xC0000409)" and the javafx application doesn't run.

// Main.java

public class Main extends Application {

@Override
public void start(Stage stage) {
stage.setScene(new Scene(new Button("Hello World"), 150, 50));
stage.show();
}

public static void main(String[] args) {
launch(args);
}
}

 

I've also tried the sample "Hello World" javafx template program provided in intellij IDEA but it gives the same error message. Simple command line program is working though. Error occurs only when I extend my class to javafx.application.Application and override the start() method.

I've tried to run the Main class from command prompt (java Main), then it works fine. I don't know why the IDE is unable to launch javafx application.

7 comments
Comment actions Permalink

I've had the same error. Managed to fix it by rolling back my NVIDIA Driver to the previous version. I was on version 378.49 and switched back to 376.33 and now everything works fine. You can give that a try regardless of your graphics card.

5
Comment actions Permalink

Problem solved. Thanks!

0
Comment actions Permalink

I can confirm that switching back to 376.33 fixed this problem for me also. I attempted to roll-back through Device manager but that gave me a BSOD, so then I went to the Nvidia website and downloaded the version directly and did a custom clean install.

0
Comment actions Permalink

I have a laptop with an NVIDIA GeForce GTX 965M and I was having the same problem.

I went to Device Manager -> Display adapters -> NVIDIA GeForce GTX 965M (Right Click) -> Properties -> Driver tab -> Roll Back Driver.

I am now back to version 376.33 and JavaFx is working once again. Thank you very much for your help. I was going crazy with this. No idea how you figured it out.

1
Comment actions Permalink

Nvidia Geforce 378.57 Hot Fix Drivers:

- Fixed crash in Minecraft and some other Java-based titles

http://www.guru3d.com/files-details/geforce-378-57-hotfix-driver-download.html

0
Comment actions Permalink

Hello,

There is a new version of the Nvidia driver (378.66).
Comparing to the driver form guru3d - you have the driver from original vendor and with newest fixes. :)
I have tested this version on my laptop (with GeForce GTX 960M).
On IntelliJ IDEA 2016.3.4 with a Swing application: it starts, works and finishes with exit code 0 on the environment console.
It seems to be ok now.

Here is what Nvidia changed since the buggy (378.49) version of their driver:
(taken from http://us.download.nvidia.com/Windows/378.66/378.66-win10-win8-win7-notebook-release-notes.pdf, page 15)
[Minecraft]: Java SE Binary crashes pointing to nvinitx.dll. [200274582]

0
Comment actions Permalink

fixed the same problem by upgrading driver to 398.36. i was having problems running code using pyqt5 and matplotlib but the driver update solved it

0

Please sign in to leave a comment.