ERROR "Unsupported startup parameter: extra_float_digits" for Postgres

Good day!

 How to overcome the error Unsupported startup parameter: extra_float_digits" for Postgres ?

9 comments
Comment actions Permalink

Hi,

Could you provide data source settings `General` tab?

Thank you.

0
Comment actions Permalink

I am also waiting for this fix. If get the same error when trying to connect to my Postgres server. If I can connect I will seriously consider getting a license.

0
Comment actions Permalink

Hi,

@Ingsoria Could you provide data source settings General tab and attach logs?

Thank you.

0
Comment actions Permalink

I had the same problem, the issue was the PgBouncer. You have to uncomment (or add) this line in pgbouncer.ini:

ignore_startup_parameters = extra_float_digits

and then run this command on the server that has the PgBouncer installed

$ service pgbouncer restart

 

https://github.com/Athou/commafeed/issues/559 

4
Comment actions Permalink

same problem as described above

0
Comment actions Permalink

Hi,

vasily chernov General tab info: connection type: default, driver: PostgreSQL, connection data private.
Error:

[08P01] ERROR: unsupported startup parameter: extra_float_digits.
.

Logs:

2019-11-05 09:47:34,030 [223301289] INFO - ution.rmi.RemoteProcessSupport - /Applications/PyCharm.app/Contents/jbr/Contents/Home/bin/java -Djava.net.preferIPv4Stack=true -Djava.rmi.server.hostname=127.0.0.1 -Duser.timezone=UTC -Dfile.encoding=UTF-8 -classpath /Applications/PyCharm.app/Contents/lib/util.jar:/Applications/PyCharm.app/Contents/lib/trove4j.jar:/Applications/PyCharm.app/Contents/lib/groovy-all-2.4.17.jar:/Applications/PyCharm.app/Contents/plugins/DatabaseTools/lib/jdbc-console.jar:/Applications/PyCharm.app/Contents/plugins/DatabaseTools/lib/dekaf-single-2.0.0.390.jar:/Users/maciek/Library/Preferences/PyCharm2019.2/jdbc-drivers/PostgreSQL/42.2.5/postgresql-42.2.5.jar com.intellij.database.remote.RemoteJdbcServer org.postgresql.Driver
2019-11-05 09:47:34,331 [223301590] INFO - ution.rmi.RemoteProcessSupport - Port/ID: 43696/RemoteDriverImpl4889ab3b
2019-11-05 09:47:34,378 [223301637] INFO - .DatabaseConnectionEstablisher - Connecting as: *** 
2019-11-05 09:47:34,379 [223301638] INFO - .DatabaseConnectionEstablisher - Connecting to: jdbc:postgresql://***:***/*** 
2019-11-05 09:47:34,877 [223302136] WARN - .DatabaseConnectionEstablisher - Connecting to: jdbc:postgresql://***:***/*** 
2019-11-05 09:47:34,877 [223302136] WARN - .DatabaseConnectionEstablisher - [08P01] ERROR: unsupported startup parameter: extra_float_digits

There is PgBouncer installed on Postgres server.

Regards,

Maciej

0
Comment actions Permalink

I'm having this issue with the following environment:

DataGrip 2019.3.4
Build #DB-193.6911.16, built on March 13, 2020
Licensed to DataGrip Evaluator
Expiration date: April 23, 2020
Runtime version: 11.0.6+8-b520.43 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Linux 5.5.7-200.fc31.x86_64
GC: ParNew, ConcurrentMarkSweep
Memory: 725M
Cores: 8
Registry:
Non-Bundled Plugins:
  • PostgreSQL 10.9 on CentOS 7
  • PGBouncer 1.8.1
0
Comment actions Permalink

Allanlewis99 Have you tried this solution ? it's about changes in pgbouncer config

0
Comment actions Permalink

Thanks, Yuriy Vinogradov - I'm trying that now.

UPDATE: Seems to work, thanks!

0

Please sign in to leave a comment.