DataGrip won't open

Completed

Any ideas on how I can get DataGrip to startup if some part of the environment configuration is invalid?

At some point I was importing large SQL files into DataGrip, it failed upon paste and prompted to increase the memory limit (or something along those lines). After that, Datagrip will not open anymore.

I tried to find any info on safe mode or where these settings are stored, haven't found it yet.

6 comments
Comment actions Permalink

Found it, figures it's been broken for 3 days and I figured it out right after posting. Hopefully it helps someone else.

I reset the following file (Windows 10):

C:\Users\{Username}\.DataGrip2016.3\datagrip.exe.vmoptions

to the same values found in:

C:\Program Files (x86)\JetBrains\DataGrip 2016.3\bin\datagrip.exe.vmoptions

Memory limits were set too high for Java's liking apparently. Ah, Java.

3
Comment actions Permalink

Thanks for posting this. I was beating my head against a wall trying to figure out why it wouldn't open. Strange it will let you change the java setting in the app to a value that will make it not open after you have closed it.

1
Comment actions Permalink

I'm having this same issue, I've restored the original file, but the app will still not launch. Did a full uninstall / reinstall and still nothing.

1
Comment actions Permalink

Hi,

Could you provide your vmoptions file?

Where have you modified your vmoptions file (location)?

Thank you.

0
Comment actions Permalink

Thanks Michael, saved me!  Up-voted you.  

1
Comment actions Permalink

Thanks Michael, was having a similar issue.  After updating to 2019.2.1, I tried running a SELECT * on small table and was met with an error recommending I increase the allocated memory in vmoptions.  After closing the application it would no longer open.  Just checked and the values in C:\Users\[username]\.DataGrip2019.2\config\datagrip64.exe.vmoptions had been changed from the custom settings I previously applied.  Not sure if it's relevant, but the -Xmx option had been changed to a value that was less than the -Xms.

In any case, problem solved, thanks again.

1

Please sign in to leave a comment.