Unable to add Python3.6 interpreter

Completed

Hello, 

I am running Windows 10.  I have been using PyCharm effectively with Python 2.7.  

I am trying to create a project with Python 3.6.  I have installed Python 3.6 properly and tested that it works.  However, when I try to add Python 3.6 as an interpreter, I get the error "The Selected file is not a valid home for Python SDK"

I have tried moving the python installation to a fully accessible folder on the root of my drive.  The Python 2.7 and Python 3.6 folders have the same permissions.  Does anyone know what I am doing wrong?

Thanks!

 

 

0
16 comments

Duplicates Zendesk support request, the problem was solved by renaming py3.exe to python3.exe.

0

I get this error " Failed to create interpreter "

Error occurred 

 

0

Hi Mazisimsebele18,

Please clarify what is your PyCharm version and attach a screenshot showing the problem.

0

 

 

 

Please help me in resolving this issue.. i am beginner

 

i am using windows 8 operating system

 

0

Hi Examrpsingh,

Have you tried running PyCharm as administrator?

In case it doesn't help, share a screenshot showing your interpreter configuration when trying to create it so I can check if everything is correct.

1

same problem even after run as adminstrator..

this is the screeenshot of creating project

0

Thank you.

Do you actually have read/write permissions to the folders and files PyCharm complaining about?

Try re-installing PyCharm from https://www.jetbrains.com/pycharm/download/ preliminary removing all the directories used by IDE https://www.jetbrains.com/help/pycharm/directories-used-by-the-ide-to-store-settings-caches-plugins-and-logs.html

You can export/import settings if you want to preserve them https://www.jetbrains.com/help/pycharm/sharing-your-ide-settings.html#import-export-settings

Has it helped?

1

hi Sergery Karpov, can you help me through team viewer

 

0

Unfortunately, we do not provide this kind of support.

If there is anything unclear, feel free to ask for more details.

0

i am unable to solve the issue

 

0

Have you followed the steps I provided?

By the way, have you tried creating virtualenv from the command line (outside of PyCharm)?

0

I don't know how to create virtualenv from the command line outside of PyCharm

0

I am facing same issue. Logged in as Admin but folder permissions show read only. I am unable to change them. Plz help

0

@Udit1002

Where do you see the folder permissions as "read only"? In PyCharm?

0

Thanks Andrey... I was able to sort the problem... Was a foolish error of 32 bit Python installed on lappy...

0

Please sign in to leave a comment.