DataGrip Azure Multi-factor authentication

Answered

Hi,

I am trying to connect to an Azure DB, however my account is configured to use Multi-factor authentication (MFA). In SQL Server Manager I connect using a method called 'Azure Universal Authentication'. (https://docs.microsoft.com/en-us/azure/sql-database/sql-database-ssms-mfa-authentication).

I've tried connecting using the latest microsoft jdbc driver, but end up getting the error:
Error code 0xCAA2000C; state 10.

Which says I need to use MFA.

Is it possible to connect in this way using DataGrip? Or what are my options?

Thanks

11 comments
Comment actions Permalink
Official comment

Yes, MFA is supported in DataGrip 2021.1 EAP 2

Comment actions Permalink

Can you please provide a timeline to when you will support MFA? '

I can also no longer use JetBrains software (PhpStorm - which I love) as you don't support MFA. A little more transparency than "we don't support it" would be greatly appreciated!

 

Thanks!

5
Comment actions Permalink

Its been almost a year, any word on AD MFA support?

1
Comment actions Permalink

@Vasily Generated a one time password and tried a couple different ways with both the microsoft and tJds flavors but no luck so far.

1
Comment actions Permalink

Is there any update on Datagrip support for MFA? It has been over two years since this issue was brought up. I am trying to log in to our Azure DBs since I turned on MFA for compliance issues, and I am stuck using Microsoft's SQL Server Management Studio. I would love to use DataGrip instead. 

1
Comment actions Permalink

I need to concur with Zuriel here, I'm using JetBrains tools for almost everything (and LOVING it) and I would love to be able to use DataGrip as well.  For me, this is a pretty large hole in my development chain.  SSMS is... just... well, BAD.   Please?  I'm not above begging.

 

Thanks,

-- Matthew

3
Comment actions Permalink

It's a great pity AAD MFA isn't supported. DataGrip is a great tool that I have been happy to pay for.

For anyone who is interested, I have just logged in to an Azure SQL Database using Microsoft's Azure Data Studio (on a Mac). ADS just connected me to a web browser window where I could select my Microsoft account. It provided me with the code to enter.

2
Comment actions Permalink

Here is feature request on our tracker, please follow and vote.

0
Comment actions Permalink

is this still not supported? this has been over years now

0
Comment actions Permalink

Good news, Microsoft finally updated their JDBC driver this month and JB implemented the Azure Active Directory interactive authentication in the latest EAP build for 2021.1.  https://blog.jetbrains.com/datagrip/2021/02/19/datagrip-2021-1-eap-2/ 

0

Please sign in to leave a comment.