PHPStorm deployment not saving username

I recently upgraded to 2017.1 from 2016.3.

After upgrading (update imported my settings from previous install), I removed the old 2016.x directory of the PHPStorm install.

When I went back into my IDE and opened a project, I noticed the Remote Host was showing "Could not connect to SFTP server at ...."

I opened the Deployment panel and saw that the username was missing.  I re-input it, clicked OK, but as soon as the panel closed, the error came back under Remote Host.  Opened Server panel again and the username was blank.

I opened several other Remote server panels (I have about a dozen different Servers), and all had the username blank.

I tried going into Settings|Deployment and entering it there, and clicking Apply, but the username value does not persist.  Interestingly, all other values (host, port, root path, keyfile names, password) all seem to be there, but it will not keep username for some reason.

I've been upgrading PhpStorm for ~4 years the same way, the only thing I did different this time was delete the old 2016.x install directory after installation was complete, to clean things up (I have all the Jetbrains IDEs so my jetbrains directory starts getting cluttered after several upgrades).

18 comments
Comment actions Permalink

Hi there,

1) What's your OS?

2) What options do you have selected at "Settings/Preferences | Appearance & Behavior | System Settings | Passwords"?

If it's other than KeePass then try choosing that option.

7
Comment actions Permalink

Thanks, Andriy

I'm on Ubuntu 16.04, and my Passwords setting is 'In native Keychain'.

Will this affect the 'username'?  Because the password seems to still be there, as well as all the other settings, just the username is missing in all my servers.

 

0
Comment actions Permalink

Andriy,

Just made change you suggested, and the usernames appear to be persisting now!  Wonder what changed?  I have never changed those settings since I started using PhpStorm 4 years ago.

Anyway, Thanks!

1
Comment actions Permalink

TBH -- no idea. I'm Windows 10 user and here I have KeePass option only ... and it works fine.

P.S. You may check your idea.log file (Help | Show Log in...) and look for some hints (errors related to this subsystem).

This one looks similar (except user had different OS): https://youtrack.jetbrains.com/issue/WI-35569 -- you may check last comment and see if it will help you.

1
Comment actions Permalink

I just upgraded on linux to 2017.3 and username and passwords aren't saved anymore which renders phpstorm useless

 

This is the error in de .idea log which is claerly about saving credentials

2018-01-22 11:59:27,877 [ 720912] ERROR - redentialStore.CredentialStore - PhpStorm 2017.3.1 Build #PS-173.3942.32
2018-01-22 11:59:27,877 [ 720912] ERROR - redentialStore.CredentialStore - JDK: 1.8.0_152-release
2018-01-22 11:59:27,877 [ 720912] ERROR - redentialStore.CredentialStore - VM: OpenJDK 64-Bit Server VM
2018-01-22 11:59:27,877 [ 720912] ERROR - redentialStore.CredentialStore - Vendor: JetBrains s.r.o
2018-01-22 11:59:27,877 [ 720912] ERROR - redentialStore.CredentialStore - OS: Linux
2018-01-22 11:59:27,877 [ 720912] ERROR - redentialStore.CredentialStore - Last Action: ShowLog
2018-01-22 11:59:28,105 [ 721140] ERROR - redentialStore.CredentialStore - secret_password_store_sync error code 32639, error message null
java.lang.Throwable: secret_password_store_sync error code 32639, error message null
at com.intellij.openapi.diagnostic.Logger.error(Logger.java:136)
at com.intellij.credentialStore.SecretCredentialStore.set(linuxSecretLibrary.kt:170)
at com.intellij.credentialStore.CredentialStoreWrapper$set$1.invoke(CredentialStoreWrapper.kt:93)
at com.intellij.credentialStore.CredentialStoreWrapper$set$$inlined$runAndLogException$lambda$1.invoke(CredentialStoreWrapper.kt:113)
at com.intellij.credentialStore.CredentialStoreWrapper$set$$inlined$runAndLogException$lambda$1.invoke(CredentialStoreWrapper.kt:36)
at com.intellij.credentialStore.CredentialStoreWrapper$queueProcessor$1.consume(CredentialStoreWrapper.kt:39)
at com.intellij.credentialStore.CredentialStoreWrapper$queueProcessor$1.consume(CredentialStoreWrapper.kt:36)
at com.intellij.util.concurrency.QueueProcessor.lambda$null$0(QueueProcessor.java:93)
at com.intellij.util.concurrency.QueueProcessor.runSafely(QueueProcessor.java:246)
at com.intellij.util.concurrency.QueueProcessor.lambda$wrappingProcessor$1(QueueProcessor.java:93)
at com.intellij.util.concurrency.QueueProcessor.lambda$null$3(QueueProcessor.java:226)
at com.intellij.util.concurrency.QueueProcessor.runSafely(QueueProcessor.java:246)
at com.intellij.util.concurrency.QueueProcessor.lambda$startProcessing$4(QueueProcessor.java:226)
at com.intellij.openapi.application.impl.ApplicationImpl$1.run(ApplicationImpl.java:315)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
at java.lang.Thread.run(Thread.java:745)
2018-01-22 11:59:28,105 [ 721140] ERROR - redentialStore.CredentialStore - PhpStorm 2017.3.1 Build #PS-173.3942.32
2018-01-22 11:59:28,105 [ 721140] ERROR - redentialStore.CredentialStore - JDK: 1.8.0_152-release
2018-01-22 11:59:28,105 [ 721140] ERROR - redentialStore.CredentialStore - VM: OpenJDK 64-Bit Server VM
2018-01-22 11:59:28,105 [ 721140] ERROR - redentialStore.CredentialStore - Vendor: JetBrains s.r.o
2018-01-22 11:59:28,105 [ 721140] ERROR - redentialStore.CredentialStore - OS: Linux
2018-01-22 11:59:28,106 [ 721141] ERROR - redentialStore.CredentialStore - Last Action: ShowLog

 

 

0
Comment actions Permalink

@Fjw

Details please. The exception does not give any hints on subsystem used etc.

1) What was the previous IDE version?

2) As per my very first comment here -- what option do you have selected at "Settings/Preferences | Appearance & Behavior | System Settings | Passwords"?

If it's Keychain -- your system may not have supported library installed (IDE does not support the one you have). Switching to KeePass should solve the issue (as it works on all platforms).

BTW: latest version is 2017.3.3 -- you seem to be using 2017.3.1.

0
Comment actions Permalink

@Andriy,

 

Thank you for your answer. The previous version was I think 2017.2. I've been storing passwords in the native keychain since the first install of PHPstorm.

I've downloaded and installed the latest release 217.3.3 which made everything work again. I think the problem started after installing the latest release through "sudo snap install phpstorm --classic" after which I thought the application was updated, but It wasn't. 

 

0
Comment actions Permalink

Not a Linux user myself so cannot give better advices. But if it will happen again (I'm mainly referring to snap package as it's a new way for PhpStorm) -- make a ticket at Issue Tracker . Right now (based on your info and the fact that re-installing helped) I can only think of some one time/random glitch.

1
Comment actions Permalink

I too can confirm this regression.

Recently updated from 2018.1.x to 

PhpStorm 2018.2.5
Build #PS-182.4892.16, built on October 11, 2018
JRE: 1.8.0_152-release-1248-b8 amd64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Linux 4.18.16

 

Was working fine before, but now it broke again.

0
Comment actions Permalink

ast, please make sure to switch to KeePass at Settings | Appearance & Behavior | System Settings | Passwords.

If it doesn't help, there's a chance it's this one: https://youtrack.jetbrains.com/issue/WI-43386

It's already fixed in current EAP: https://www.jetbrains.com/phpstorm/eap/

0
Comment actions Permalink

Changing the setting to KeePass worked like a charm.

Thank you.

 

Please note that running the EAP did not solve the problem for me.

Also I opened up a new thread https://youtrack.jetbrains.com/issue/WI-44005  when I realized that no of the issues here were working.

 

 

0
Comment actions Permalink

I have the same issue.

- Input "User name".

- Press "Apply".

- And filed "User name" is cleared.


MasOS Mojave Version 10.14.5

OZU: 8Gb

0
Comment actions Permalink

Have you tried my suggestion to switch to KeePass?

0
Comment actions Permalink

I did not try to switch to KeePass.

I just uninstall PhpStorm in Toolbox.

And after that remove folders:
~/Library/Preferences/
~/Library/Caches/
~/Library/Application Support/
~/Library/Logs/

grep -i brain and remove them

I got the list of those folders from article: https://intellij-support.jetbrains.com/hc/en-us/articles/206544519-Directories-used-by-the-IDE-to-store-settings-caches-plugins-and-logs


And after that, I solved this issue.

Now "Apply" does not clear "User name" 

0
Comment actions Permalink

Happens on 2019.2 as well.... bloody annoying...

 

Aug 1, 2019:

Te be a bit more elaborate, I am on kubuntu 19.04, using the ssh keypair

(so no password)

Below i entered the username and hit the test connection button this is correct

 

 

After i clicked the apply button

not so good... :(

 

So lets upload something to aws...

0
Comment actions Permalink

Same problem on Rubymine 2019.1 on Linux (no password manager). Upgrading to 2019.2 didn't change anything.

0
Comment actions Permalink

So .. what's your settings for passwords? Using KeePass should work on any platform.

Show a screenshot of your settings for that.

0
Comment actions Permalink

@kees

Please show your "Settings (Preferences on macOS) | Appearance & Behavior | System Settings | Passwords"

0

Please sign in to leave a comment.