Auto completion is not working on the community edition. Is it normal ?

Answered

Hello,

I’ve installed the community edition of the JAVA editor IntelJ IDEA, which version is given below:

IntelliJ IDEA 2016.3.5

Build #IC-163.13906.18, built on March 6, 2017

JRE: 1.8.0_112-release-408-b6 x86

JVM: OpenJDK Server VM by JetBrains s.r.o

I have configured the following settings:

 

  • File > Project Structure
  • File > Settings... > Editor > General > Code Completion

 

Below I show the configurations:

File > Project Structure


File > Settings... > Editor > General > Code Completion


Ans, at the end, I restarted the editor by clicking on :

File > Invalidate Caches / Restarts...

Please note that I am using Windows 7. Java is well installed and works correctly (both the JRE and the JDK). The code I am working on the correct (it compiles and executes).

Did I miss something ?

I have consulted the forum, and other sites also. But I can’t figure out what’s missing.

Any help should be greatly appreciated.

Regards,

Denis

 

 

6 comments
Comment actions Permalink

Please share a sample project and a video of the problem.

0
Comment actions Permalink

Hello,

Thank you for your help.

I have pushed the code on GitHub:

https://github.com/denis-beurive/java-introduction

For the video, I am not equipped. However, I can take some pictures of the screen. I’ll do that tomorrow.

Regards,

Denis

0
Comment actions Permalink

Make sure "src" directories are configured as Source roots in your projects: https://www.jetbrains.com/help/idea/configuring-content-roots.html.

0
Comment actions Permalink

Hello Serge,

It works fine.

Thank you very much,

Denis

0
Comment actions Permalink

this first time i used this IDE, make one class " hellow word " but i got the same trouble when i type System. not showing any code i can choose, have try the add content root but not working

0

Please sign in to leave a comment.