Updating an earlier version of Data Grip makes the 32 Bit version not working

Updating an earlier version of Data Grip makes the 32 Bit version not working

I have a DataGrip 2016.2.6 which if I update it find conflicts:

And produces an error log

Temp. directory: C:\Users\az\.DataGrip2017.1\system\tmp\patch-update

java.io.IOException: Cannot delete: C:\Program Files (x86)\JetBrains\DataGrip 2016.2.6\jre\jre\bin\server\classes.jsa
    at com.intellij.updater.Utils.tryDelete(Utils.java:104)
    at com.intellij.updater.Utils.access$000(Utils.java:25)
    at com.intellij.updater.Utils$1.visitFile(Utils.java:76)
    at com.intellij.updater.Utils$1.visitFile(Utils.java:73)
    at java.nio.file.Files.walkFileTree(Files.java:2670)
    at java.nio.file.Files.walkFileTree(Files.java:2742)
    at com.intellij.updater.Utils.delete(Utils.java:73)
    at com.intellij.updater.CreateAction.prepareToWriteFile(CreateAction.java:114)
    at com.intellij.updater.CreateAction.doApply(CreateAction.java:84)
    at com.intellij.updater.PatchAction.apply(PatchAction.java:200)
    at com.intellij.updater.Patch.lambda$apply$2(Patch.java:330)
    at com.intellij.updater.Patch.forEach(Patch.java:380)
    at com.intellij.updater.Patch.apply(Patch.java:320)
    at com.intellij.updater.PatchFileCreator.apply(PatchFileCreator.java:83)
    at com.intellij.updater.PatchFileCreator.apply(PatchFileCreator.java:75)
    at com.intellij.updater.Runner.doInstall(Runner.java:314)
    at com.intellij.updater.Runner.lambda$install$0(Runner.java:281)
    at com.intellij.updater.SwingUpdaterUI.lambda$doPerform$2(SwingUpdaterUI.java:194)
    at java.lang.Thread.run(Thread.java:745)

The original file cannot be launched for error:

---------------------------
Error launching DataGrip
---------------------------
The environment variable JAVA_HOME (with the value of C:\Java\jdk1.8.0_92) does not point to a valid JVM installation.
---------------------------
OK   
---------------------------

Which appears to be not true. There is a working jdk there.

Now, when I run the 64 Bit version of Data Grip it may work, and it wants to update itself which results in the above error - chasing its tail.

I appear to have been unable to upgrade Data Grip.

7 comments
Comment actions Permalink

I am experiencing the same issue. Not able to upgrade DataGrip. Please help!

0
Comment actions Permalink

Same for me

0
Comment actions Permalink

Same problem here: DataGrip is functioning perfectly fine (running the 64-bit exe).

When it tries to update, it gags while trying to over-write a bunch of stuff in its own JRE directory. Probably something to do with Windows permissions.

Screencaps below.

 




0
Comment actions Permalink

In my case, solved by choose "SKIP" option for ver 2017.01

0
Comment actions Permalink

From Ver 2017.01 to 2017.02 (crash again and don't start) don't open "datagrip.exe" instead open "datagrip64.exe"

0
Comment actions Permalink

The latest patch (to 2017.1.2) worked - it threw one jre-related 'keep/overwrite' warning... after that everything went smoothly. (I should mention again, that I'm using the 64-bit exe).

0
Comment actions Permalink

Hi,

There were some issues with patching and x32/x64 jdk.

As a workaround, you need to reinstall DataGrip. But for smooth upgrade / downgrade you need use Toolbox App https://www.jetbrains.com/toolbox/app/

Thank you.

0

Please sign in to leave a comment.