Auto-closing the open file pop-up box

Answered

When using the Open File pop-up box to navigate around, it will sometimes randomly close a few times before I can actually type into it.

 

I use this functionality all the time on my Windows machine without any issue, but I'm using Ubuntu 14.04 LTS and that's the environment I'm experiencing this issue. My version is Phpstorm 2017.1.4.

32 comments
Comment actions Permalink

Hello,

Could you reproduce this and then look for any errors in Help > Show Log > idea.log please? Anything coming up there?

0
Comment actions Permalink

Hi! Thanks for the response. After having it happen a few more times, there is nothing in the log associated with it or during the time that it happened. I can keep checking it in case something comes up.

0
Comment actions Permalink

Okay, so it doesn't populate an entry every time it happens, but it looks like this is associated with my issue:

 

2017-05-22 08:11:34,139 [2060150]   WARN - ellij.openapi.ui.DialogWrapper - Stale listener: com.intellij.ide.ui.laf.LafManagerImpl$OurPopupFactory$1@7384bf69 

0
Comment actions Permalink

Hi,

Are you trying to navigate around metwork mounted folders?

0
Comment actions Permalink

I am not. This is a local project. Is there any log info I can print out that would help? (Besides the one line I have above)

0
Comment actions Permalink

You can upload your idea.log file to our FTP (links are here) right after the issue reoccurs. Just let us know the name of the file once uploaded

0
Comment actions Permalink

Cool, I uploaded from https://uploads.services.jetbrains.com/ and named it "popup_close_treed"

 

The think the last three lines are the culprit.

0
Comment actions Permalink

Thanks!

What theme do you have in File | Settings | Appearance & Behavior | Appearance?

0
Comment actions Permalink

Darcula.

0
Comment actions Permalink

Please try to disable Color Ide (2.3) plugin.

0
Comment actions Permalink

I uninstalled the plugin and it is still happening.

It seemingly stopped the issue for maybe 10 minutes, but it's happening again. I tried disabling more plugins that I don't actually use to see if that will help.

 

I really appreciate your persistence in trying to help me solve this!

0
Comment actions Permalink

I've disabled every plugin besides the essentials, and the problem persists.

0
Comment actions Permalink

Please try:

1. open settings Registry (Ctrl+Shift+A and look for "Registry...")
2. Find "allow.dialog.based.popups" and disable it

 

What shortcut (menu item) exactly are you using? Like ctrl+shift+N?

1
Comment actions Permalink

I'm using ctrl+o

0
Comment actions Permalink

That seemed to be the trick! It hasn't happened since I updated that "allow.dialog.based.popups" setting.

1
Comment actions Permalink

Please test it out for a while to make sure that did the trick, thanks!

0
Comment actions Permalink

This problem has started back up since upgrading to Phpshstorm 2017.2. I still have the 'allow.dialog.based.popups' set to off and ColorIDE uninstalled.

0
Comment actions Permalink

Does it occur on Open File or Open Class? I recall there was a new unrelated issue with "Open class" action.

0
Comment actions Permalink

I was experiencing with Open File, I hadn't tried the Open Class function.

 

For now I've reverted back to 2017.1.4, but was curious why it had started occurring again.

0
Comment actions Permalink

Looks like the issue is still not addressed: https://youtrack.jetbrains.com/issue/IDEA-112015 (and workaround seems to no longer work in 2017.2)

0
Comment actions Permalink

I really appreciate your prompt responses! I'll stick with 2017.1.4 for a while then. Thanks for looking into this. :D

0
Comment actions Permalink

I also experience this issue on 2017.2  with or without "allow.dialog.based.popups" trick.

Case :
search File/Class with keyboard shortcut (Ctrl+N) or Menu -> Navigate -> Class

Problem :
At first search, no problem, popup always shows and stay displayed
After few usages (2-3 times), problem appears.
Now, if popups shows with already filled text (after text selection in editor or last text typed in search popup) the search popups shows with results list and immediatly closes. If I press 10 times Ctrl+N, popup works 1 time, or never...

It's like if suggestion list makes popup lost focus and closes, and the worst is the search text is written in the editor since there is no popup...

Info :
PhpStorm 2017.2 Build #PS-172.3317.83, built on July 18, 2017 Licensed to ***
JRE: 1.8.0_152-release-915-b5 amd64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o Linux 4.10.0-28-generic
Ubuntu GNOME 17.04.
Intel Core i7-7700K, 16GB RAM

 

0
Comment actions Permalink

Work around: Disable Hide navigation popups on focus loss in Settings > Appearances & Behavior > Appearance. It appears the popup loses focus as once this workaround is applied, hitting CTRL+N then immediately typing will highlight the focus is on the IDE and not the popup.

This is also occurring on Webstorm 2017.2, for both navigating to File and Class.

I'm on Ubuntu (Gnome) 17.04, JRE 1.8.0_152-release-915-b5 AMD64, Ryzen 1700, 32GB RAM.

Side note: I also have a Macbook Pro and the issue is not present on that machine.

5
Comment actions Permalink

This worked for me, thank you Bernie!

0
Comment actions Permalink

I've tested all the tips that have gone in the last comments.
But what worked for me was to keep BOTH these options enable in settings Registry (Ctrl+Shift+A and look for "Registry...")


* focus.follows.mouse.workarounds - enabled
* allow.dialog.based.popups - enabled

0
Comment actions Permalink

The most successful combination I found so far was:

Hide navigation popups on focus loss -> false

focus.follows.mouse.workarounds -> enabled

allow.dialog.based.popups -> disabled

(idea.popup.weight -> doesn't seem to have any effect with allow.dialog.based.popups disabled)

 

This seems to work some of the time, but sometimes the popup appears but the cursor continues focused on the editor.

 

I'm running IntelliJ 2017.2.2 EAP and i3wm 4.13 with focus mouse.

When focus mouse is disabled, I have no issues at all.

 

Edit:

Using actionSystem.xWindow.remove.focus.from.nonFocusable.popups=false instead of focus.follows.mouse.workarounds=true seems to be doing the trick

0
Comment actions Permalink

Have exactly same issue with Intellij on Ubuntu 17.10

0
Comment actions Permalink

Please also follow the updates of https://youtrack.jetbrains.com/issue/IDEA-173000

 

The issue is addressed in a next major update + next EAP (will be ready this Wednesday) should also include the fix

1
Comment actions Permalink

Disabling hiding on focus loss worked for me. Thanks!

0
Comment actions Permalink

Thanks guys. This topic saved my life.

 

I used: 

Hide navigation popups on focus loss -> false

allow.dialog.based.popups -> disabled

actionSystem.xWindow.remove.focus.from.nonFocusable.popups=false

0

Please sign in to leave a comment.