Date format does not appear in the dropdown menu when importing tables

Answered

When importing a CSV file, a cannot put in the DATE format for a column because it's simply not there. I am having to import it through a different IDE and then open in DataGrip. I am working in Postgres database and that format does indeed exist, and works properly in all other IDEs but not in DataGrip. Any ideas why that could be happening?

Sam 

 

5 comments
Comment actions Permalink

Hi,

Could you provide sample CSV and table DDL to reproduce the problem?
Thank you.

0
Comment actions Permalink

I also have this problem. It would be great to be able to specify the format the date is in. I'm currently unable to import because the date is in a weird format.

0
Comment actions Permalink

O Polden,

So, could you provide a sample DDL and a sample CSV to reproduce the issue?

0
Comment actions Permalink

ok, let see my samples

database - clickhouse

table:

create table esia_dev.test1
(
id Int32,
name String,
date Date
)
engine = Memory;

CSV file to import:
ID#NAME#DATE
1#X1#22.10.19
2#X2#23.10.19
3#X3#24.10.19

import settings form:

 

and error log:
2:6: conversion failed: "22.10.19" to date (date)
3:6: conversion failed: "23.10.19" to date (date)
4:6: conversion failed: "24.10.19" to date (date)

0
Comment actions Permalink

I created issues:
- https://youtrack.jetbrains.com/issue/DBE-11964 (to specify date/time format before import)
- https://youtrack.jetbrains.com/issue/DBE-11965 (type conversion issue in ClickHouse)

0

Please sign in to leave a comment.