New Spring Boot "Run dashboard" not showing up

Answered

I've a Maven Project which is a Spring Boot Project. What do I have to do for the new Run dashboard to appear? Would like to try it out.

 

Cheers,

Jan

24 comments
Comment actions Permalink

What IntelliJ IDEA version do you use? It's available in 2017.2: https://www.jetbrains.com/idea/nextversion/.

0
Comment actions Permalink

I'm aware that this has been added to 2017.2
I'm on the public preview and want to try it out.

IntelliJ IDEA 2017.2 EAP
Build #IU-172.3198.6, built on June 27, 2017
IntelliJ IDEA EAP User
Expiration date: July 27, 2017
JRE: 1.8.0_152-release-915-b4 amd64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Linux 4.4.0-83-generic

0
Comment actions Permalink

Did you read https://blog.jetbrains.com/idea/2017/05/intellij-idea-2017-2-eap-run-dashboard-for-spring-boot/ ?

Did you add `-Dide.run.dashboard=true` in Help | Edit Custom VM Options and restarted IntelliJ IDEA?

0
Comment actions Permalink

Yeah of course I've read it. But after reading this https://blog.jetbrains.com/idea/2017/06/intellij-idea-2017-2-public-preview/ it sounded to me that the param isn'T required with the Public Preview anymore.

Anyhow after adding it the Run Dashboard is available.

Would be nice if the Public Preview blog post would be updated to reflect the requirement of the flag.

Cheers,
Jan

0
Comment actions Permalink

Thanks for the info, we'll update the blog post.

0
Comment actions Permalink

Does this only work with the Ultimate version of IntelliJ? Because I tried the VM options and also the registry, and the Run Dashboard still isn't showing up. I'm using IntelliJ 2017.3 Community.

0
Comment actions Permalink

Hi there,

I still can't get the Run Dashboard window to appear... 

IntelliJ IDEA 2017.3.4 (Ultimate Edition)
Build #IU-173.4548.28, built on January 29, 2018
JRE: 1.8.0_152-release-1024-b11 amd64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Linux 4.13.0-32-generic

Any idea how to get it to work ?

This are my VM options

# custom IntelliJ IDEA VM options

-Xms128m
-Xmx750m
-XX:ReservedCodeCacheSize=240m
-XX:+UseConcMarkSweepGC
-XX:SoftRefLRUPolicyMSPerMB=50
-ea
-Dsun.io.useCanonCaches=false
-Djava.net.preferIPv4Stack=true
-XX:+HeapDumpOnOutOfMemoryError
-XX:-OmitStackTraceInFastThrow
-Dawt.useSystemAAFontSettings=lcd
-Dsun.java2d.renderer=sun.java2d.marlin.MarlinRenderingEngine
-Dide.run.dashboard=true


Thanks

 

0
Comment actions Permalink

Do you have several Spring Boot Run confiigurations?

0
Comment actions Permalink

Yes. Is that a problem ? :-/

0
Comment actions Permalink

I bet your problem is the following:
Go to configurations, there you have to define which types of configurations you want in the Run Dashboard.

I really don't get the idea behind this and think this is really a bad decision to hide this but after I added Spring Boot to the list of Run Dashboard configurations it worked for me.

3
Comment actions Permalink

But in the "Defaults" list I don't have Run Dashboard...

0
Comment actions Permalink

Okay I found the collapsed display "Configurations available in Run Dashboard" at the bottom of "Defaults" screen.
Thanks for the help.

4
Comment actions Permalink

Yeah really I don't get what the JetBrains guys did here...

1
Comment actions Permalink

I would just like to add that this solved the issue for me with checking at the bottom of the Defaults screen and adding Spring Boot to the list of "Configurations available in Run Dashboard" which was prior empty. Annoyingly in the various JetBrains blog posts like on https://blog.jetbrains.com/idea/2017/05/intellij-idea-2017-2-eap-run-dashboard-for-spring-boot/ this crucial step was missed off (unless the process has changed since then) which kept me guessing for about 2 hours. It would be nice if this was made obvious somewhere.

0
Comment actions Permalink

I agree, it's not very intuitive. Thanks to Gregory Bishop (and Jan Thewes) for your suggestions.

1
Comment actions Permalink

I'm running IntelliJ IDEA 2018.2.4 (Ultimate Edition),  In a brand new project (gradle), I was somehow able to get the Run Dashboard to show up, though I don't recall what I had to do to enable it.  However, I've since added a spring boot module to a larger, existing, gradle project.  In Run > Edit Configurations, it shows up as a Spring Boot configuration, and I'm able to run that just fine from there.  However, there's no option to "Show in Run Dashboard", as I've seen mentioned elsewhere. Also, I don't see any place to add Spring Boot to the list of "Configurations available to Run Dashboard".   Where is this defined?  I've looked in Run/Debug Configurations, System Settings, and Project Structure, 

0
Comment actions Permalink

In the Run/Debug Configurations Popup, you should have "Spring Boot" and also "Templates".
If you select 'Templates' you should see "Configurations available to Run Dashboard" at the bottom.

3
Comment actions Permalink

Doh!  OK, I see it now.  Thanks!

To be clear, this is in the right side, when you click on "Templates" (and not any of the actual templates underneath)  You see "Click the + button to create a new configuration based on the templates at the top".   

I must have initially clicked the expansion and was looking for something at the bottom of that list, or something called "Default" based on prior comments. 

4
Comment actions Permalink

yes, this is really hard to find, Please make it more obvious, Jetbrains team!

0
Comment actions Permalink

Hello,

IntelliJ IDEA 2019.2.1 (Ultimate Edition)
Build #IU-192.6262.58, built on August 20, 2019
Licensed to IntelliJ IDEA Evaluator
Expiration date: September 6, 2019
Runtime version: 11.0.3+12-b304.39 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o

I added -Dide.run.dashboard=true in the gradle VM options, in each SpringBoot application and in Help -> Edit custom VM options.

When I open Edit configurations -> Templates I see at the bottom "Configuration available in Services" instead of "... in Run Dashboard".

 

When I press Ctrl+Shift+A I find "Run Dashboard (Services)" which does nothing.

Can't see "Run Dashboard" tab in the bottom (next to "Version Control" for example).

Any help?

0
Comment actions Permalink

It looks like they migrated the `Run Dashboard` display to `Services` but it still does the same job.

IntelliJ IDEA 2019.2.1 (Ultimate Edition)
Build #IU-192.6262.58, built on August 20, 2019

0
Comment actions Permalink

My version is also IntelliJ IDEA 2019.2.1 (Ultimate Edition), 

Yes, the spring run dashboard now becomes 'services'  , yet there are 2 issues

1. services are not in the bottom tabs, which should show in the View - > tool windows list, it's not there either. 

2. when opening a multiple spring boot applications, it doesn't detect the spring boot automatically every time.  ( in some cases it does ). 

0
Comment actions Permalink

@Ross Bu for p.1 could you please provide a screenshot, and for p.2 is there any steps to reproduce a problem?

0

Please sign in to leave a comment.