Lost main menu after MacOS update


Updated my macbook to MacOS High Sierra beta yesterday and lost main menu bar. Now when i move a mouse cursor to the top of the screen i see only "IntellJ IDEA" and no other menu items like File Edit View... Is here any thoughts how to fix it? It's really annoying to reinstall system back.


I also did lost, here's what I did to temporarily fix the problem:

Open/Create a new file ~/idea.properties with the following line:

apple.laf.useScreenMenuBar = false

Now the menu appears on the window, like in MS Windows, but hey... it works...


I am also having this same issue on one machine but not another. One is a MacBook Pro mid-2012 non-retina @1280x800. The other is a 2014 MacBook Air @ 1440x900.


I will try the laf fix. I am not sure why one works and the other does not but there are some odd messages in the console log.


I have also noticed that the keystrokes are not recognized for cmd-q, etc. Not sure if this is the mnemonics but native MacOS X key combos do not work. IntelliJ key combos do.


Installing the legacy java from https://support.apple.com/kb/dl1572?locale=en_US fixed it for me on High Sierra.


High Sierra now prevents you from installing Legacy Java as outlined above


I can confirm installing an older version of Java will work and I am using the latest High Sierra beta, in order to install legacy JavaVM you will need to start up in recovery mode and rename the JavaVM.framework from terminal.

Its a pita but it does allow you to exit the jetbrains IDE's and edit preferences without command/option finger dance.


just followed @Ee05265 tip and work as a charm :D


It works enough to make IntelliJ useful again, but you still can't access the IntelliJ menu properly


Hey Ee05265 thanks for your suggestion.

I was facing a big problem with IntelliJ (14.1.7) where I was not able to open any dialog box of IntelliJ. The problem was that - If you click on File > open or any try to open any other dialog box like "Find in Files" or anything else, nothing happens. No dialog box appears.

I solved my problem after disabling the default menu of MacOS Sierra by your suggestion.

Now my menu bar is inside IntelliJ app. But the good part is - IntelliJ is at least working now.

Thanks again @Ee05265 for suggestion.


Thanks a bunch Ee05265! Your suggestion worked for me as well!


Please sign in to leave a comment.