@NotNull/@Nullable not added when generating getter/setter from annotated field


I thought it worked at some point but not any more for me. (I am on latest EAP)

It works for me in constructors but getter/setter generation stubbornly refuse to do so.

I have these annotations (jetbrain's ones) marked to be used in code generation but still it is not working

I am wondering  if it ever worked because In velocity variable documentation there is no mention/support for any annotation checks for a field (or method) so there is no API to be used in velocity script to introspect field annotations to craft proper velocity template

If I am missing something please point me in right direction. If it is a limitation I think I will create a ticket to expose field annotations in velocity templates 

Comment actions Permalink

I don't recall it working in previous versions (tried with IDEA 15, 2016 and 2017.1).

I've noticed that you've already submitted a related issue at https://youtrack.jetbrains.com/issue/IDEA-176763. Please follow it for updates.

Comment actions Permalink

Thanks Serge!


Please sign in to leave a comment.