How to disable automatic double quote insertion after typing an equal sign(WebStorm)?

I just started using WebStorm recently(as well as I'm new to html, CSS and JavaScript) and I almost instantly ran into this usability problem. When I type something like <div id=, it will automatically add quote marks and put my cursor inside them: <div id="I". But when I finish entering id name of this tag <div id="whatever", I have to press RightArrow key to continue typing my code, because if press " key after typing id name, it will actually insert one more quote mark and I end up with something like <div id="whatever"". At this point I either have to press Backspace key and then RightArrow key or Delete key.

Here's how it looks like in motion(you can see which keys I press in the bottom right corner):

It is much easier to just type quote mark(press shift+' keys) than to press RightArrow key. It also makes much more sense to me. Therefore I ask if there is a way to disable double quote mark insertion after I type equal sign or if I can make IDE to move my cursor to the right side of the second quote mark after I press Shift+' keys, instead of inserting another quote mark...

Yes, I've read some topics about it:

https://intellij-support.jetbrains.com/hc/en-us/community/posts/207044965-Autocomplete-insertion-double-quotes-after-start-typing-html-tag-attribute

https://youtrack.jetbrains.com/issue/IDEA-113332

But was unable to find a solution for it. Is there some plugin to fix this problem or something, if developers haven't fixed it themselves 4 years after this bug has been reported originally?

 

9 comments
Comment actions Permalink

Woah, I finally fixed it:

File-Settings-Editor-Code Style-HTML-Other tab, set Generated quote marks to None:

Well, I wish that people in the future will find this thread easily. I just randomly stumbled on that specific settings after long time of googling and parsing through the settings.

 

Mygosh, I swear these auto completion technologies of quote marks and parenthesis only make it worse, not better!

7
Comment actions Permalink

to me, extra quote entered within id value is "eaten", so i don't need to delete it. Anyway, you can disable quotes auto-inserting by turning off Add quotes for attribute value on typing '=' and attribute completion in File | Settings | Editor | General | Smart Keys

7
Comment actions Permalink

Both mine and your solutions work for me.

But how do you make second quote mark eaten?

0
Comment actions Permalink

I don't do anything special - as soon as I enter extra quote within

id="myid"

, the closing quote is deleted

Please see the video at ftp://ftp.intellij.net/pub/.idea/video/Recording #304.mp4

0
Comment actions Permalink

Well, yeah, I reinstalled my WebStorm(deleted all settings and history) and now it works for me too:

Probably checked some random checkbox by mistake.

0
Comment actions Permalink

Thanks for the first comment! 

I was considering going back to notepad++ for HTML editing because I hate the default way quotes work- takes about an extra 15s+ to get them to work right each time- I can only assume they would be good for someone dumb and lazy xD (who either can't take the time to remember to put quotes around values in HTML, or doesn't realize quotes are needed).

<div id

<div id="" (auto generates double quotes when you type '=' before you type a quote)

<div id="""my-id (typed first quote and the thing you are putting in your quote)

(oh crap, doing something the way it is done in all other editors or even notepad doesn't work)

(delete id and 3 quotes, try to add a quote, get 3 quotes, delete 3rd quote, use arrow keys to move into the auto generated quotes, finally get your id name inside your quotes).

Someone either really hates efficient html, or doesn't believe in remembering quotes on attributes O.o

 

Thanks for the fix! 

1
Comment actions Permalink

Elena had the correct answer for me... thanks!  Should not make something that is sooooo annoying soooo hard to find!  Should be under code style > html instead of smart keys.  An IDE shouldn't make it more difficult to code, but this one does, out of the box, until you spend hours finding all these annoyances and correcting them. Then, and only then, is it a good IDE.

0
Comment actions Permalink

Thanks, it's the same on Rider (so few people use Rider that Google automatically knows to search for IntellJ/WebStorm/etc.).

I'm sorry but the auto-insert squigglies, parentheses, quote marks, corner brackets, etc. needs to stop. 

1
Comment actions Permalink

I agree.  I use Rider for C# .NET Core programming, and I hate the IDE inserting a matching ", {, (, etc...screws me up more than it helps me when I type to code as I generate fewer compile bugs me doing it than the IDE doing it for me...I just need the IDE to highlight the matching ",},) etc and I'm good.

 

In Rider for Linux, where is File-Settings-Editor-Code Style-HTML-Other tab, set Generated quote marks option?  See screenshot- I'm using the Visual Studio IDE keymap.  I have Jet brains rider 2018.3.5:

0

Please sign in to leave a comment.