Read Only issues with Auto-Commit

After spending all day with this I'm at the end of my rope. 

Folks on StackOverflow say to toggle Auto-Commit. That works, but I have to close and re-open DataGrip between every single query. 

My job requires me to edit lots of fields on the fly, which is the main reason I chose DataGrip. The only way to avoid this it to switch Transactions to Manual, but this adds more steps and time to my workflow. 


I've fought with this multiple times before and then it just magically goes away after a day or two. It always comes back after every single DataGrip update, each update makes my user experience worse. 

 

 

 

13 comments
Comment actions Permalink

EDIT: When set to Auto, it now tells me when I attempt to edit a cell: "This table is read only. Search path mismatch"

 

First attempt at a query and subsequent edit after a DataGrip re-start works just fine with AutoCommit on. Any queries and attempts at an edit after requires a restart, over and over. 

 

This is just flat-out unusable. 

0
Comment actions Permalink

Hi,

Could you describe your steps to reproduce, define database you use?

Thank you.

0
Comment actions Permalink

SQL Server 2012

Steps:

Open DataGrip > SELECT * FROM dbo.foo (Can edit fields in table at will) > SELECT * FROM dbo.foo (Table is read-only. Search path mismatch)

 

I have to close and re-open DataGrip, and each time the FIRST query I run will allow me to edit. Any and all subsequent queries and an attempt at an edit result in "Table is read-only. Search path mismatch"

If I close DataGrip and re-open, same result. 

 

I have switched to DBeaver. 

0
Comment actions Permalink

I have the same issue with "Table is read-only. Search path mismatch" in DataGrip 2017.2.1. 

I'm using a FirebirdSQL - JDBC driver to connect to a FirebirdSQL database. This behaviour seems to have been introduced with 2017.2.1 or 2017.2 as I had no difficulty updating records in earlier versions.

This issue was resolved for me with 2017.2.2

0
Comment actions Permalink

Almost the same issue:

I am getting "Table is read-only. Unresolved table reference". I have Synchronized the DB and tried the rechecking the Read Only option multiple times.

0
Comment actions Permalink

Same problem, postgres. Just downloaded this product today & already hit this apparently insurmountable bug. The SO question on this issue is over 2 yrs old and it's apparently still a problem. Would be great to see a response from JB. 

0
Comment actions Permalink

@brandonmp Hi,
Could you define steps to reproduce your problem by providing your data source settings and test query?
Thank you.

0
Comment actions Permalink

@Anton 
I had the same issue with "Table is read-only. Unresolved table reference". I noticed that one of the columns in my select query is yellow colored because the column was added by another developer and I have not synchronized table after that. Although that I could see query result in console I couldn't edit it. The problem was solved by synchronization of the table.

0
Comment actions Permalink

@ Edvard Davtyan 
One can edit query result set only for simple queries. 

 

0
Comment actions Permalink

@vasily_chernov
What do you consider as "simple query"? About all the queries that I use is available for editing.

0
Comment actions Permalink

If it is a  simple select statement then you can edit result set.

 

0
Comment actions Permalink

Hmmz I think this is related to the edit window...

If I use this field to write my where clause it works:

Because the results are shown in the main window.

However if I execute the following(which is the same) query from the Scratch file:

SELECT * FROM CasinoMappings WHERE casinoName LIKE '%playtech%';

The result are shown in the Result Window and are NOT editable!

0
Comment actions Permalink

@Anton

Yes, you're right. Actually, grid editor and result set editor is different functionality. For now, result set editor can be edit only for simple select statements.

There are some issues you can track:

0

Please sign in to leave a comment.