IntelliJ magnifies after computer sleeps

Answered

Upon starting up IntelliJ, everything works normally and everything is the correct size. If I close my laptop (putting it to sleep) and then open it again, IntelliJ is extremely magnified and I cannot get it back to normal without exiting out and then starting intelliJ again. It is essentially unusable while extremely zoomed in. I am a new user, and I didn't see any posts about it on the forum. Is this a problem with an easy solution I am just not seeing, or is something about my computer settings causing this? Any help would be greatly appreciated.

Here is how it should normally look:

Here is how it looks when i return after shutting my laptop.

Thank you!

3 comments

Serge, thank you for the quick response! That article you wrote does describe my problem. Unfortunately changing font sizes and having it manually override did not help. Additionally, setting the VM Option did not appear to do anything.

After looking into some links you had in your article and their comments, I found that Daniel Fallon's comment on https://youtrack.jetbrains.com/issue/JRE-427 led me to check this "Disable display scaling on high DPI settings" which fixed my solution. If you could add this to your other article to help people that would be amazing!

3

Thanks for the above solution. I had a slightly different menu for RubyMine. This is what worked for me (the "Override high DPI scaling behavior" setting):

 

4

Please sign in to leave a comment.