Rubymine gem scanning problem

Answered

I need to disable gem scanning in ruby mine, it makes rubymine just unusable.

I tried to add ruby.gem.scanner=false into idea.properties file as stated in: https://intellij-support.jetbrains.com/hc/en-us/community/posts/206933065-Rails-Developement-Turn-off-search-for-gems but that didn't changed a thing.

I need an answer ASAP. So much work to do, and so many problems with this gem scanning...

 

Kind Regards,
Mariusz Roszkowski

13 comments
Comment actions Permalink

Hello Mariusz, deeply sorry for delay. The reason of scanning might be different, but this is definitely bug. Could you please share all folder with logs? According logs we could suggest workaround. See how to:

https://intellij-support.jetbrains.com/hc/en-us/articles/206544519-Directories-used-by-the-IDE-to-store-settings-caches-plugins-and-logs.

0
Comment actions Permalink

I was trying my best to work with your product with better and worse results. I'm coming back to this topic because I feel like I can't stand it anymore. From time to time java on my linux is consuming all processor while reading  my disk. Closing RubyMine helps so its obvious where problems comes from. It must be gem scanning. I simply asked you how to turn this OFF and guess what? No one cares, no one helps. Maybe I should start to think about another IDE? I can share log files but there is no way to attach it to this post. SHAME on you.

0
Comment actions Permalink

Hello,

regarding gems' scanning we have a corresponding request: https://youtrack.jetbrains.com/issue/RUBY-17585 So you can vote for it in order to follow it.
As for logs and dumps, you can send them to rubymine-support@jetbrains.com

0
Comment actions Permalink

Hi, I'd like to add onto this. I can't disable the scanner. I added the config value like the original poster did and it still scans the Gemfile and automatically updates my Gemfile.lock file, which is both unexpected and unwanted. Is there a way to disable this permanently?

It's a pretty old problem it seems https://intellij-support.jetbrains.com/hc/en-us/community/posts/206933065-Rails-Developement-Turn-off-search-for-gems

 

0
Comment actions Permalink

You can also try turning off 'Missing gems' inspection and 'Gem Manager' notifications (Settings | Appearance & Behavior | Notifications).

0
Comment actions Permalink

Hi Olga - they are turned off and I still see the behavior.

I can provide a video if you'd like.

0
Comment actions Permalink

I've rechecked and yes, even with the inspections disabled RubyMine will still scan for gem requirements because it's necessary for detecting the project's dependencies.

0
Comment actions Permalink

I understand, but the modifying of the Gemfile.lock file is still really unexpected. Any chance we can have a setting for that?

0
Comment actions Permalink

We have a corresponding request so you can add your vote there and follow it: https://youtrack.jetbrains.com/issue/RUBY-11114

0
Comment actions Permalink

Thanks Olga. I added to that.

0
Comment actions Permalink

I'd like to re-open this old problem: https://intellij-support.jetbrains.com/hc/en-us/community/posts/206933065-Rails-Developement-Turn-off-search-for-gems

My case is subtly different. In Linux environment, the "scanning for gem requirements" happens about every 10 seconds and can't be turned off (AFAICT).  When the files server on which some of the gems lives becomes slow or unresponsive, the scan stalls and hangs my Rubymine until the file server can respond.  This has been as long as a few minutes.

In our environment, the contents of these global, file-server-based GEM paths cannot change.  It would be good if we could have a switch to disable the automatic scanning, or better yet, a place where we can specify which paths should be scanned at startup only?

0
Comment actions Permalink

Tony Ivanov, have you tried the workaround proposed in the thread you mentioned?

0
Comment actions Permalink

Yes, this workaround does perform a single scan at startup, but then does not perform any additional scans.

This is OK for now - would be nice to have exclude-list.  Can you create an enhancement request for this and put in your backlog?

0

Please sign in to leave a comment.