Built in web server is not working

I get either "This site can’t be reached" when trying to open an html file. No server was set up by default. Here are the settings I've tried.






 

3 comments
Comment actions Permalink

Hi there,

1) So .. do you have a web server (Apache/nginx/IIS/etc) installed on your computer?

Or you referring to the built-in simple web server that WebStorm comes with? If so -- it uses 63342 port (can be checked in Settings/Preferences) ... ad not 80 (default for http) as on your screenshots.

P.S. If you do not use any Deployment entry (e.g. files no need to be copied anywhere) then built-in web server will be used anyway.

2) When using built-in web server .. the URL should contain project name (localhost:63342/PROJECT_NAME_HERE/file.html) in order for IDE to know what project should be served as all projects are served via the same port (so it acts like domain name in proper web server).

 

Based on the above -- please clarify what URL it/you trying to open when it does not work.

If it all good -- anything interesting in idea.log (Help | Show Log in...)

1
Comment actions Permalink

I am facing the same issue.

Webstorm Version:

WebStorm 2021.2
Build #WS-212.4746.80, built on July 23, 2021
Licensed to *****
Subscription is active until *****.
Runtime version: 11.0.11+9-b1504.13 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
Windows 10 10.0
GC: ParNew, ConcurrentMarkSweep
Memory: 1979M
Cores: 12
Non-Bundled Plugins: one.util.ideaplugin.screenshoter (1.7), PlantUML integration (5.5.1)


Step 1: 

 

Step 2:

 

Step 3

0
Comment actions Permalink

Norma Mendonca Not sure I understand what the issue has to do with the IDE. Does this URL work if you open your page outside of the IDE? Is your web server (that listens on https://r2-ui:63342) up and running?

0

Please sign in to leave a comment.