Windows Terminal PATH is missing environment variables


 I just reinstalled Windows 10 and I can't get the Terminal window to inherit the PATH correctly.

When I open a terminal and type PATH, the following is displayed.

PATH=C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\Users\Tony\AppData\Local\Microsoft\WindowsApps;

When I open a terminal in Windows the following is displayed

PATH=C:\ProgramData\Oracle\Java\javapath;E:\Python\Python36\Scripts\;E:\Python\Python36\;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;E:\Git\cmd;E:\node\node-v6.11.5-win-x64;E:\java\jdk1.8.0_151;E:\java\jdk1.8.0_151\bin;C:\Users\Tony\AppData\Local\Microsoft\WindowsApps;


I need to be able to run AWS, NPM, and such commands.  What am I missing?



Comment actions Permalink

What I have found is if I run IntelliJ from the JetBrains toolbox window, the above scenario occurs.


However if I go find the executable and double click on it, then the path shows up correct.  Does anyone know why that is? 

Comment actions Permalink

Does it help if you restart Toolbox? Do you run Toolbox using the same user account?

Comment actions Permalink

Restarting Toolbox worked for me.

Comment actions Permalink

I had to restart the Computer so solve it


Please sign in to leave a comment.