Redshift Disconnect

Answered

On my Mac (10.12.6 (16G29)), if I leave DataGrip idle for more than a few minutes, DataGrip disconnects from my Redshift cluster...   or more precisely, DataGrip frequently thinks its connected when it is not and only lets you know when trying to run a query you recieve an error...   it doesn't seem able to figure out how to reconnect and I have to close DataGrip and reopen the program to reconnect.

This is mildly frustrating...  however the real block has now come from long running copy processes...  I run a copy command that takes a couple hours.  Datagrip appears to sustain an active connection...  but just as the copy reaches 100% in the Amazon Interface, it drops the connection (maybe it thinks its successful) but apparently leaves Redshift hanging...  so Redshift panics and unloads all the data it spent 2hrs sending to the cluster.

The comment from Redshift Support was:

I got the reply the internal team, they were suspecting the problem 
to be with the client from which you were running the COPY command,
the client might have got disconnected from the redshift without
COMMITing the COPY command.   

What client you were using to run the COPY command?

Make sure that you have enabled the "autocommit" to "on",
so that the COPY command commit all the changes to the tables.

In the DataGrip UI, yes, Tx: is set to "Auto"...   unless it should be something else?

Hopefully the solution fixes both of my problems that are apparently rooted in premature disconnects.

6 comments
Comment actions Permalink

I also tried adjusting the laptop timeouts.

specifically changing:

mmartimoMacBook:~ mmartimo$ sudo sysctl net.inet.tcp.always_keepalive=1
net.inet.tcp.always_keepalive: 0 -> 1

I still get:

0
Comment actions Permalink

Hi,

Don't you have any troubles with your network connection?
Also, there is an issue https://youtrack.jetbrains.com/issue/DBE-5294 you can track and vote for.

Thank you.

0
Comment actions Permalink

This also happens to me. Very annoying. I've voted for that issue. Here's hoping.

0
Comment actions Permalink

Please escalate this issue.

0
Comment actions Permalink

likewise. super annoying

0
Comment actions Permalink

Have the same issue. Please provide a solution.

0

Please sign in to leave a comment.