Center align editor code outside of distraction free

Answered

Hi I really like how the code center aligns in "distraction free mode". However as soon as I want to debug something I have to exit.

In distraction free mode breakpoints are not visible and don't seem to work even though I can show the debugger panel with shortcuts.

Is this possible? all I could see was hard wrapping with columns.

Thanks

 

0
23 comments

Thanks adding "-Deditor.distraction.free.mode=true" in Help | Edit Custom VM Options. works :)

0

Hi, I tried this same option in CLion 2018.1 via the Edit Custom VM Options. But nothing changed. Does it matter where you place it in the clion64.exe.vmoptions ??

0

No, it doesn't matter, just have to be a separate line.

0

After PyCharm upgrade to a new version had to restart it twice to for the solution to work.

0

After I did that, distraction free just stop working

0

Enter/Exit Distraction free mode will restore the original behavior. This option is to force the distraction free mode for the editor only without hiding the tool windows, so you normally use one or another, not both at the same time.

0

I'd like to use distration free pattern again in default mode (without flat behaviour ) but even after removing the flag, the original behavior doesn't come back. Even after reinstalling an IDE.

0

Check that you don't have the flag in Help | Edit Custom VM Options. I can't reproduce the problem.

0

The flag is not in the file.

 

 

0

Check in Help | Find Action | Registry:

2

The flag is being updated correctly, the problem is that when distraction free is enabled the toolbars keep popping up

0

I fixed it removing directory ~/Library/Preferences/IntelliJIdea*  and restarting the IDE. 

Thanks.

0

Is there a way to drag the centering as in how it is done with the tool windows?

0

Would it be possible to center vertically?

0
Not automatically. You can try to adjust the value of Settings (Preferences on macOS) | Advanced Settings | Left margin in distraction free mode.
0

Beware that the bug with -Deditor.distraction.free.mode=true breaking hiding panels in distraction free mode even after it's removed is still present in Android Studio Hedgehog | 2023.1.1 Patch 2 which is based on IntelliJ IDEA 2023.1.

It's fixed by resetting to default settings, and reapplying the needed settings afterwards may be bothersome.

Maybe exporting settings before trying it and importing them in case of a problem would work. Haven't tried.

0

Hello, Vlad M. Could you please describe the problem in more detail? Have you already reported it to our issue tracker before? 

0

Hello, Olga Mulina , so the issue is what Adriano mentioned this issue in this thread. I tried to make my editor text centered by adding the -Deditor.distraction.free.mode=true parameter. It did work, but when I entered the distraction-free mode, the side panels weren't hidden like before adding the parameter. I removed the parameter and restarted the IDE, but the problem with the panels staying was still occurring. I've tried -Deditor.distraction.free.mode=false parameter, but it didn't help either.

Considering that resetting IDE config helped, and that Adriano solved the problem also by resetting the config, it seems that adding -Deditor.distraction.free.mode=true changes something in the config, and then it's not changed back.

I didn't report it so far. I'm not sure if I'm ready to invest time in it (reproducing, recording video, etc). But there's a backup of a config which the IDE created before reverting the changes. I can provide the relevant parts from there if it would be helpful.

I'm using Windows 11 Pro x64 Build 22631.

0

Dear users, setting the registry flag or VM option directly does not now switch the IDE to distraction free mode fully like it did before, so I would not recommend using this approach in the current IDE version to avoid unpleasant side effects. 

There is an existing feature request to allow customizing Editor left margin in normal mode, kindly upvote IDEA-155052.

0

Please sign in to leave a comment.