docker registry config with private registry

Answered

I have a private docker registry that I use. It's insecure in that it is just using self signed certs. It is fronted, however, by nginx. Pycharm tries to send http requests to it, in which case I get errors from nginx. How can I fix that? Is it in my build settings for Docker?

Thanks!

4 comments
Comment actions Permalink

I have the same/similar issue. Docker pull just simply does not work at all from our private repository :(

Credentials are correct as Settings->Docker->Registry shows 'Connection successful'

I generally use "docker pull <repository hostname>:<repository port>/<image name>" as in a terminal.

So if I use "<repository hostname>:<repository port>/<image name>" as is in the 'Repository' field of the 'Pull Image' dialog, then I get error message:

com.github.dockerjava.core.exception.InvalidRepositoryNameException: Repository name "<repo>:<port>/<image>" is invalid. Component: <repo>:<port>

Instead, if I give "<image name>" only in the 'Repository' field of the same dialog, I get (way too quickly) an informative message that it pulled successfully the image, but in reality it doesn't pull anything, because neither anything shows in the docker tool window nor it is listed via the terminal. I can actually literally write any image name, and it still comes back saying pulled successfully...

EDIT: my biggest problem seems to be that the docker plug-in automatically appends the username as part of the image being pulled. While I'd like it to do: "docker pull <repo>:<port>/<image>" it seems PyCharm is doing "docker pull <repo>:<port>/<username>/<image>"

2
Comment actions Permalink

Same here, the plugin is appending the username, and i can't download the images by intelliJ

0
Comment actions Permalink

There is a known bug with docker registry https://youtrack.jetbrains.com/issue/PY-31756, feel free to vote and leave comments.
EDIT: if your issue is not covered by the ticket, please report another ticket and attach logs Help | Show Log in... with steps for reproducing.

0
Comment actions Permalink

I decided this as follows: in the configuration of the private repository, I entered the repository instead of the username. And when I execute "Pull image ...", I enter a space in the repository name.

0

Please sign in to leave a comment.