Edit Triggers in Oracle with DataGrip

Completed

Hi Folks:

I'm in the process of trying to learn to use DataGrip.

I can't figure out how to edit certain Oracle things like Triggers, Functions, etc.

Am I missing some setting that would show them?   Below is a screen pic of what I see.

Thanks,

Matthew

P.S. I did find under each table a blank folder called "Triggers" but these do not contain any of the triggers that I know are 'on' the tables and that other IDE's can see.

2 comments
Comment actions Permalink

Hi,

Try to invoke "Forget schemas..." action and synchronize your datasource again. Make sure you've got triggers. If there are no triggers in DataGrip database tree, please attach IDE logs and sample DDL.

In general, to edit a trigger you need to choose it in tree and open editor to edit source code.

Thank you.

P.S.: to avoid yellow code you need include all needed schemas into introspection scope.

0
Comment actions Permalink

Hi vasily:

Thank you for the advice. I tried that but it still didnt work. What did work was my updating my jdbc driver to the latest Oracle version and then i did the 'forget schemas'.  With the new driver and then doing your suggestion  worked.

thanks!

Matthew

1

Please sign in to leave a comment.