Autoformat adds line break after semicolon

Answered

I want more than one statement in one line, I can't find the option to stop autoformat from adding a newline after any semicolon.

for example:

string s; cin >> s;
int idx, x; cin >> idx; idx--;

is always changed to

string s;
cin >> s;
int idx, x;
cin >> idx;
idx--;

when I reformat, but I don't want that to happen.

3 comments
Comment actions Permalink

I am having this same issue and would love a solution to it. I can't find any answers online.

0
Comment actions Permalink

This really makes me annoying. How can I disable this feature

0

Please sign in to leave a comment.