Disable automatic aliases in code completion

Answered

I just updated to DataGrip 2017.3, and now when I use code completion for a join, DataGrip automatically adds an alias:

select *
from foos
inner join bars b on b.foo_id = foos.id

Before, it would complete with the table name:

select *
from foos
inner join bars on bars.foo_id = foos.id

I can't stand queries that are peppered with unreadable aliases. Is there a way to disable this? Or even control what aliases DataGrip selects for each table? Join completion doesn't save me any time when I have to edit the result, and that feature is really the only reason I use DataGrip to begin with.

Edit: It appears that there is a workaround: Rather than selecting the completion when typing the table name, finish typing the table name and select the completion after typing "on". That at least saves the effort of typing out the join condition, although you can't autocomplete the table name. I'd still like to know how to disable this.

3 comments
Comment actions Permalink

Yes, please add an option to disable table auto-aliasing.

1
Comment actions Permalink

You can disable this by unchecking "Use aliases in completion for JOIN" in the Editor/General/Code Completion preferences.

0
Comment actions Permalink

@Cimbul, @John Marriott, @ RenePrillop,

There are some settings for aliases completion

0

Please sign in to leave a comment.