RN 0.51.0 and Metro Blunder

Hello All,

 

I just upgraded to RN 0.51.0 and tried to run my app from WebStorm. I noticed that I see the "Metro Blunder" as my packager.

 

In order to run the same way as the older react-native version. What do I need to do differently in WebStorm.

 

Has anyone tried the Metro Blunder with Webstorm or the late React Native with WebStorm? What config changes did you have to make?

I would greatly appreciate someone's help or comment on this.

 

Thanks,

Fredi

51 comments
Comment actions Permalink

Good morning, Elena,

I had a meeting with our senior management. 

We need the fix for this problem very soon. This is hindering our progress and would greatly appreciate a release with these fixes in it.  Can we have a fix either today or Monday? Considering that "running debugger" is one of the most important features of your software/product and I am sure many off your other customers are waiting for your software to be operational again. 

I would greatly appreciate your team's support on this matter.

Thanks,

Farshid

0
Comment actions Permalink

The fix was backported to 173.* branch (see 'Fixed in Builds' field), so it will be included in the nearest 2017.3.3 EAP (https://confluence.jetbrains.com/display/WI/WebStorm+EAP) that can be expected next week. Please follow WebStorm blog (http://blog.jetbrains.com/webstorm/) and Twitter (https://twitter.com/webstormide) to be notified when it's available

0
Comment actions Permalink

Great, thanks a lot for your support.  I look forward to the release. 

Have a wonderful weekend,

Farshid

0
Comment actions Permalink

Hello Elena,

 

I hope you had a nice weekend. 

 

I tried to vote for the issue so I would get notification on this fix but it doesn't allow me. It's say: You cannot vote for resolved issues.

Is the code with the fix released yet? If not, could you tell me when please, and also notify when it's released.

 

Thanks,

Farshid

0
Comment actions Permalink

No, the EAP that includes the fix is not yet available; you can follow our blog (http://blog.jetbrains.com/webstorm/) to be notified when it's announced

0
Comment actions Permalink

Hello Elena,

 

I hope all is well. I assume this build has the fix for my problem? Please confirm. Thanks.

 

WebStorm 2017.3.3 is now available

WebStorm 2017.3.3 (173.4301.22) is now available!

As always, you can install this update using Toolbox App. If you’re using WebStorm 2017.3.1, 2017.3.2 or 2017.3.3 EAP, you will soon see an update notification in the IDE. If you are using an earlier WebStorm version, please download WebStorm 2017.3 from our website.

New in WebStorm 2017.3.3:

  • Responses from the new REST Client are now formatted automatically (WEB-28672)
  • Node.js debugger now supports –experimental-modules flag (WEB-30325)

What’s fixed:

  • False positive errors from the eslint-plugin-import ESLint plugin were fixed (WEB-30497)
  • Debug for apps created with Angular CLI 1.5.5+ (WEB-30035)
  • Debugging the app’s main process with Electron 1.8.1+ (WEB-29655)
  • Meteor debugger now uses –inspect by default (WEB-30124)

You can look through the full list of addressed issues in the Release notes.

WebStorm Team

 

 


0
Comment actions Permalink

Unfortunately, I tried the latest build and I still cannot run the debugger. I am getting the same error. WAS THIS CODE TESTED?

0
Comment actions Permalink

/usr/local/Cellar/node/7.4.0/bin/node --debug-brk=59778 --expose_debug_as=v8debug /Applications/WebStorm.app/Contents/plugins/JavaScriptDebugger/proxy/launcher.js --port=8081 --sourcesStoragePath=/Users/farshidi/src/rn51InnovaMobile/.tmp/reactNativeBuild
Debugger listening on 127.0.0.1:59778

0
Comment actions Permalink

I wonder why --debug-brk=4471 --expose_debug_as=v8debug are used for debugging..what Debugger process is chosen in Run configuration? Can you attach screenshot?

0
Comment actions Permalink

Any update? 

0
Comment actions Permalink

Please change Debugger process to 'Chrome' - 'Node' doesn't work currently (https://youtrack.jetbrains.com/issue/WEB-29972)

0
Comment actions Permalink

Ok. Thanks. When would the "Node' version work?  What is the expected time of release for that fix? 

Thanks,

Farshid

0
Comment actions Permalink

there is no ETA for this fix. What's wrong with using Chrome instead?

0
Comment actions Permalink

I find the "Node' version much smoother. I look forward to your announcement on the release date for the 'Node' version. Meanwhile, I continue with the Chrome version. 

Once again, thanks for your support.

Take care, 

Farshid

0
Comment actions Permalink

I am,definitley, looking forward to the 'Node' version of the debugger. I found the 'Chrome' version very cumbersome and unstable to use so far. I would appreciate your kind attention to this matter and have your team release the 'Node' version soon. Thanks a lot. 

0
Comment actions Permalink

Hello Elena,

 

I hope allis well. I was wondering if you have any update on the 'Node' version of this release. What is the estimated release date?

 

Thanks,

Farshid

0
Comment actions Permalink

I'm fine, thank you:) Hope all is good with you.

No updates, sorry.

Just vote for https://youtrack.jetbrains.com/issue/WEB-29972 - you will be notified on any update. Also, you can ask the responsible developers questions by submitting comments to youtrack ticket

0

Please sign in to leave a comment.