Keyboard issues with right alt and polish keyboard layout

Answered

My env: Win10, Intellij 2017.3, Logitech g510s (both alt say 'alt' - no altgr), system lang - us, input method - polish programmers keyboard

In all JetBrains IDEs right alt behaves like ctrl+alt. If I want to use polish letter ż - Ralt+z IDE reads it as ctrl+alt+z and reverts changes. Supper annoying. Almost all polish accented letters are affected and so few other shortcuts that should work with ctrl+alt but work also with Ralt.

I searched a lot because its super annoying but either problems were back from 2008 and resolved or didn't match my case.
I also tried the following (true and false) but it didn't work.

actionSystem.force.alt.gr=true

 

28 comments
Comment actions Permalink

Yes, still no solution though

0
Comment actions Permalink

Does it work correctly in other Java Swing applications like JEdit and NetBeans?

0
Comment actions Permalink

Just installed netbeans and no, the problem does not exist. Both alt keys are highliting menu bar (File Edit View... ) but only left alt+V opens View menu.

0
Comment actions Permalink

Try adding -Dcom.jetbrains.use.old.keyevent.processing=true in Help | Edit Custom VM Options.

By the way, where did you add actionSystem.force.alt.gr=true option?

See if switching Runtime to Oracle Java 8 helps: https://intellij-support.jetbrains.com/hc/articles/206544879.

0
Comment actions Permalink

I put it in idea.properties. Perhaps it should start with -D as this one you provided. I only have jdk and jre 8.

It works now with actionSystem.force.alt.gr=true and -Dcom.jetbrains.use.old.keyevent.processing=true
Are there any side effects of that?

EDIT: 
It works with only actionSystem.force.alt.gr=true

0
Comment actions Permalink

-D should be added if you add it in Help | Edit Custom VM Options, Help | Edit Custom Properties works without -D.

0
Comment actions Permalink

Ah, alright, I was putting it in Help | Edit Custom Properties.
Adding 

-Dcom.jetbrains.use.old.keyevent.processing=true

to VM Options doesn't fix it.

The working solution is to add actionSystem.force.alt.gr=true to custom properties. Thank you

0
Comment actions Permalink

I have the same problem during writing commit message in PhpStorm and WebStorm also.

I've set

actionSystem.force.alt.gr=true

but Polish letters still don't work. When I use alt +o (which means ó), I can see that Optimize imports checks or unchecks. It's weird.

My system is OSX 10.14.2 . Keyboard Polish pro. PhpStorm is 2018.3.3 and WebStorm is 2018.3.3.

0
Comment actions Permalink

Have you tried -Dcom.jetbrains.use.old.keyevent.processing=true ?

0
Comment actions Permalink

Yes, it doesn't work.

Only works ż and ź. When I type alt and o, l, n, a I can see that options during commit (Before commit section) are checking or unchecking.

0
Comment actions Permalink

Damian, what keymap do you use - is it OsX 10.5+?

0
Comment actions Permalink

I'm using IntelliJ:
IntelliJ IDEA 2018.3.2 (Ultimate Edition)
Build #IU-183.4886.37, built on December 17, 2018
macOS 10.14.2

Keymap: OsX 10.5+

There seems to be no shortcuts for those letters (ć or ź) but still doesn't work. when I press option+letter. 

Update of IntelliJ + change as suggested:
> Please, go to Help -> Edit Custom Properties
> Add the next property into the file
> com.jetbrains.use.old.keyevent.processing=true


Solved issue for me.

1
Comment actions Permalink

I use Default keymap in PHPStorm and WebStorm.

Here is quick video, when I click option and "o" , "l" or "c" . Checkboxes are checked or unchecked.

Adding com.jetbrains.use.old.keyevent.processing=true, -Dcom.jetbrains.use.old.keyevent.processing=true, actionSystem.force.alt.gr=true do not solve my problem.

0
Comment actions Permalink

See https://youtrack.jetbrains.com/issue/IDEA-169195.

Alt triggers mnemonics, but that could be disabled. Try changing ide.mac.alt.mnemonic.without.ctrl to false in IDE Regsitry (Find Action - Registry)

3
Comment actions Permalink

Disable mnemonics in controls solved problem !

Thank you.

1
Comment actions Permalink

Exactly the same problem. 
I'm working with Intellij for some time and this appeared recently. I updated Mac to Mojave. It might happen I updated Intellij as well - I do not know but this problem is quite new. 
It's really sad and more people will notice it every day.



Still does not work for me.

2
Comment actions Permalink

-DactionSystem.force.alt.gr=true

helps me on windows 10

0
Comment actions Permalink

The new update has broken it again :(

0
Comment actions Permalink

None of these work for me.

There's always at least one polish letter that won't work.

Tried:  disabling mnemonics, actionSystem.force.alt.gr, actionSystem.fix.alt.gr (through registry and through properties).

Version: 2019.2

0
Comment actions Permalink

This is getting ridiculous. I have to keep chrome tab open and CTRL+C CTRL+V single letters.

0
Comment actions Permalink

OK. Changed the runtime to JBR to the following:

Still didn't help.

What is are the recommended settings again? I tried different options (through registry, VM options, etc.), but got lost in this.

0
Comment actions Permalink

You need to try JBR 11.0.4 runtime. Choose jbrsdk-11_0_4...-b494...

0
Comment actions Permalink

Changing the JRE didn't make any difference.

But you know what's funny? I actually played a bit with registry options, and found something like ide.mac.alt.mnemonic.without.ctrl. I've disabled it and it "kind of" helped.

At least the polish letters appear in the editor. However some of them, like alt-z or alt-n still bring up the menu, but at least it's better than how it was before.

If you want me to try some different options, please let me know. I tried enabling actionSystem.force.alt.gr and also tried actionSystem.win.suppressAlt - These don't help. 

0

Please sign in to leave a comment.