No module named 'dash' - but dash latest version is installed

Answered

I have verified that I has dash latest version and I've installed it in Pycharm after the pip install. In pycharm I've tried running the script both with venv and with a system interpreter (Python 3.11). I have also tried rebooting the machine.

No matter what I do, I have been stuck for hours getting an error when simply trying to 'import dash'.

import dash
ModuleNotFoundError: No module named 'dash'

Process finished with exit code 1

0
10 comments

It doesn't seem to be related to PyCharm, as it's Python that cannot find it, not PyCharm.
Make sure you installed it into the same environment that you use in PyCharm. You can use PyCharm's interface to manage packages https://www.jetbrains.com/help/pycharm/installing-uninstalling-and-upgrading-packages.html

0

Hi Sergey
Thanks for the inputs.

I think indeed it is a PyCharm specific issue. When I run the file through CMD directly it runs just fine.

In  PyCharm's interface I have tried uninstalling and reinstalling dash, and as mentioned also running the file through a venv and a system interpreter. 

The bottomline is I can't make dash run through Pycharm, but it runs outside Pycharm.

 

One thing that surprises me is that when I click install inside Pycharm I'll get a lille notification confirming the install, but after that I can still click 'install package' - I would assume that button should change after the install.

 

0

Do you see it in PyCharm among the installed packages?

0

Could you run the following code with the same interpreter both in PyCharm and in the command line and provide the outputs?

import sys
import os
import pkg_resources
from pprint import pprint

pprint({
'sys.version_info': sys.version_info,
'sys.prefix': sys.prefix,
'sys.path': sys.path,
'pkg_resources.working_set': list(pkg_resources.working_set),
'os.environ': {
name: value.split(os.pathsep) if 'PATH' in name else value
for name, value in os.environ.items()
},
})
0

Yes absolutely. The output is very long. But see it below.

Running in CMD:

C:\Users\Simon>python test.py
{'os.environ': {'ALLUSERSPROFILE': 'C:\\ProgramData',
                'APPDATA': 'C:\\Users\\Simon\\AppData\\Roaming',
                'COMMONPROGRAMFILES': 'C:\\Program Files\\Common Files',
                'COMMONPROGRAMFILES(X86)': 'C:\\Program Files (x86)\\Common '
                                           'Files',
                'COMMONPROGRAMW6432': 'C:\\Program Files\\Common Files',
                'COMPUTERNAME': 'LAPTOP-12NBBS2N',
                'COMSPEC': 'C:\\Windows\\system32\\cmd.exe',
                'DRIVERDATA': 'C:\\Windows\\System32\\Drivers\\DriverData',
                'HOMEDRIVE': 'C:',
                'HOMEPATH': ['\\Users\\Simon'],
                'LOCALAPPDATA': 'C:\\Users\\Simon\\AppData\\Local',
                'LOGONSERVER': '\\\\LAPTOP-12NBBS2N',
                'NUMBER_OF_PROCESSORS': '12',
                'ONEDRIVE': 'C:\\Users\\Simon\\OneDrive',
                'ONEDRIVECONSUMER': 'C:\\Users\\Simon\\OneDrive',
                'OS': 'Windows_NT',
                'PATH': ['C:\\Windows\\system32',
                         'C:\\Windows',
                         'C:\\Windows\\System32\\Wbem',
                         'C:\\Windows\\System32\\WindowsPowerShell\\v1.0\\',
                         'C:\\Windows\\System32\\OpenSSH\\',
                         'C:\\Program Files\\dotnet\\',
                         'C:\\Users\\Simon\\AppData\\Local\\Programs\\Python\\Python311',
                         'C:\\Windows\\system32',
                         'C:\\Windows',
                         'C:\\Windows\\System32\\Wbem',
                         'C:\\Windows\\System32\\WindowsPowerShell\\v1.0\\',
                         'C:\\Windows\\System32\\OpenSSH\\',
                         'C:\\Program Files\\dotnet\\',
                         'C:\\Users\\Simon\\AppData\\Local\\Microsoft\\WindowsApps',
                         'C:\\Users\\Simon\\AppData\\Local\\Programs\\Python\\Python311\\Scripts',
                         'C:\\Program Files\\PostgreSQL\\13\\bin',
                         ''],
                'PATHEXT': ['.COM',
                            '.EXE',
                            '.BAT',
                            '.CMD',
                            '.VBS',
                            '.VBE',
                            '.JS',
                            '.JSE',
                            '.WSF',
                            '.WSH',
                            '.MSC'],
                'PROCESSOR_ARCHITECTURE': 'AMD64',
                'PROCESSOR_IDENTIFIER': 'AMD64 Family 23 Model 96 Stepping 1, '
                                        'AuthenticAMD',
                'PROCESSOR_LEVEL': '23',
                'PROCESSOR_REVISION': '6001',
                'PROGRAMDATA': 'C:\\ProgramData',
                'PROGRAMFILES': 'C:\\Program Files',
                'PROGRAMFILES(X86)': 'C:\\Program Files (x86)',
                'PROGRAMW6432': 'C:\\Program Files',
                'PROMPT': '$P$G',
                'PSMODULEPATH': ['C:\\Program '
                                 'Files\\WindowsPowerShell\\Modules',
                                 'C:\\Windows\\system32\\WindowsPowerShell\\v1.0\\Modules'],
                'PUBLIC': 'C:\\Users\\Public',
                'SESSIONNAME': 'Console',
                'SYSTEMDRIVE': 'C:',
                'SYSTEMROOT': 'C:\\Windows',
                'TEMP': 'C:\\Users\\Simon\\AppData\\Local\\Temp',
                'TMP': 'C:\\Users\\Simon\\AppData\\Local\\Temp',
                'USERDOMAIN': 'LAPTOP-12NBBS2N',
                'USERDOMAIN_ROAMINGPROFILE': 'LAPTOP-12NBBS2N',
                'USERNAME': 'Simon',
                'USERPROFILE': 'C:\\Users\\Simon',
                'WINDIR': 'C:\\Windows'},
 'pkg_resources.working_set': [click 8.1.3 (c:\users\simon\appdata\roaming\python\python311\site-packages),
                               dash-table 5.0.0 (c:\users\simon\appdata\roaming\python\python311\site-packages),
                               dash 2.11.1 (c:\users\simon\appdata\roaming\python\python311\site-packages),
                               Flask 2.2.3 (c:\users\simon\appdata\roaming\python\python311\site-packages),
                               Werkzeug 2.2.3 (c:\users\simon\appdata\roaming\python\python311\site-packages),
                               itsdangerous 2.1.2 (c:\users\simon\appdata\roaming\python\python311\site-packages),
                               dash-core-components 2.0.0 (c:\users\simon\appdata\roaming\python\python311\site-packages),
                               dash-html-components 2.0.0 (c:\users\simon\appdata\roaming\python\python311\site-packages),
                               xyzservices 2023.5.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               certifi 2022.12.7 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pytz 2022.6 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pywin32 305 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               setuptools 65.5.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pyzmq 24.0.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pip 23.2.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               attrs 22.1.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               argon2-cffi 21.3.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               packaging 21.3 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               argon2-cffi-bindings 21.2.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               PyQt6-sip 13.4.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               websockets 10.4 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               Pillow 9.4.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               mss 9.0.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               ipython 8.7.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               tenacity 8.1.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               ipywidgets 8.0.4 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               jupyter-client 7.4.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               nbconvert 7.2.5 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pytest 7.2.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               ipykernel 6.23.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               notebook 6.5.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               jupyter-console 6.5.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               PyQt6 6.4.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               PyQt6-Qt6 6.4.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               tornado 6.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               PyYAML 6.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               plotly 5.11.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               psutil 5.9.4 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               nbformat 5.7.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               traitlets 5.6.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               zope.interface 5.5.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               qtconsole 5.4.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               decorator 5.1.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               jupyter-core 5.1.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               bleach 5.0.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               DateTime 5.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               tqdm 4.65.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               fonttools 4.38.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               jsonschema 4.17.3 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               beautifulsoup4 4.11.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               lxml 4.9.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               typing-extensions 4.4.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               exchange-calendars 4.2.8 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pandas-market-calendars 4.1.4 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               widgetsnbextension 4.0.5 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               matplotlib 3.7.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               anyio 3.6.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               Markdown 3.4.3 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               idna 3.4 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               Jinja2 3.1.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               bokeh 3.1.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pyscreenshot 3.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               prompt-toolkit 3.0.33 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               openpyxl 3.0.10 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pyparsing 3.0.9 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               jupyterlab-widgets 3.0.5 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               colorcet 3.0.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               requests 2.28.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               jupyterlab-server 2.22.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pycparser 2.21 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               fastjsonschema 2.16.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               Pygments 2.13.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               Babel 2.12.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               psycopg2 2.9.5 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               python-dateutil 2.8.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               platformdirs 2.5.4 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               soupsieve 2.3.2.post1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               QtPy 2.3.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pyviz-comms 2.2.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               asttokens 2.2.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               markdown-it-py 2.2.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pyluach 2.2.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               snakeviz 2.2.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               MarkupSafe 2.1.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               charset-normalizer 2.1.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pywinpty 2.0.9 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               mistune 2.0.4 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               greenlet 2.0.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               linkify-it-py 2.0.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               iniconfig 2.0.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               urllib3 1.26.13 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               numpy 1.23.5 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               jupyter-server 1.23.3 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               holoviews 1.16.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               six 1.16.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               cffi 1.15.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               param 1.13.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               scipy 1.10.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               finplot 1.9.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pyperclip 1.8.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               ansi2html 1.8.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               Send2Trash 1.8.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pynput 1.7.6 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               debugpy 1.6.7 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               nest-asyncio 1.5.6 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pandas 1.5.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pandocfilters 1.5.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               rfc3986 1.5.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               SQLAlchemy 1.4.46 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               kiwisolver 1.4.4 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               websocket-client 1.4.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               dash-bootstrap-components 1.4.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               retrying 1.3.4 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               sniffio 1.3.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               tinycss2 1.2.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               executing 1.2.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               chart-studio 1.1.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               EasyProcess 1.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               entrypoint2 1.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               et-xmlfile 1.1.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               polygon 1.1.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               PyMsgBox 1.0.9 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pytweening 1.0.7 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               contourpy 1.0.7 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               panel 1.0.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               uc-micro-py 1.0.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               jupyter 1.0.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pluggy 1.0.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               httpx 0.23.3 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pyrsistent 0.19.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               jedi 0.18.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               cufflinks 0.17.3 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               terminado 0.17.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               httpcore 0.16.3 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               prometheus-client 0.15.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               h11 0.14.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               statsmodels 0.13.5 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pyqtgraph 0.13.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               seaborn 0.12.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               toolz 0.12.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               cycler 0.11.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               PyAutoGUI 0.9.54 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               json5 0.9.14 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               ipympl 0.9.3 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               tabulate 0.9.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               hvplot 0.8.3 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               parso 0.8.3 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pickleshare 0.7.5 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               nbclient 0.7.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               defusedxml 0.7.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               mouse 0.7.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               jupyter-contrib-nbextensions 0.7.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               stack-data 0.6.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               jupyter-nbextensions-configurator 0.6.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               patsy 0.5.3 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               webencodings 0.5.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pyct 0.5.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               nbclassic 0.4.8 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               colorama 0.4.6 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               jupyter-contrib-core 0.4.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               entrypoints 0.4 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               voila 0.4.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pandas-ta 0.3.14b0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               mdit-py-plugins 0.3.5 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pyinput 0.3.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               korean-lunar-calendar 0.3.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               colorlover 0.3.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               wcwidth 0.2.5 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               jupyterlab-pygments 0.2.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               notebook-shim 0.2.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pure-eval 0.2.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               kaleido 0.2.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               PyRect 0.2.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               backcall 0.2.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               ipython-genutils 0.2.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               jupyter-highlight-selected-word 0.2.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               PyScreeze 0.1.29 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               matplotlib-inline 0.1.6 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               MouseInfo 0.1.3 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               comm 0.1.3 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               mdurl 0.1.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               PyGetWindow 0.0.9 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages)],
 'sys.path': ['C:\\Users\\Simon',
              'C:\\Users\\Simon\\AppData\\Local\\Programs\\Python\\Python311\\python311.zip',
              'C:\\Users\\Simon\\AppData\\Local\\Programs\\Python\\Python311\\Lib',
              'C:\\Users\\Simon\\AppData\\Local\\Programs\\Python\\Python311\\DLLs',
              'C:\\Users\\Simon\\AppData\\Roaming\\Python\\Python311\\site-packages',
              'C:\\Users\\Simon\\AppData\\Local\\Programs\\Python\\Python311',
              'C:\\Users\\Simon\\AppData\\Local\\Programs\\Python\\Python311\\Lib\\site-packages',
              'C:\\Users\\Simon\\AppData\\Local\\Programs\\Python\\Python311\\Lib\\site-packages\\win32',
              'C:\\Users\\Simon\\AppData\\Local\\Programs\\Python\\Python311\\Lib\\site-packages\\win32\\lib',
              'C:\\Users\\Simon\\AppData\\Local\\Programs\\Python\\Python311\\Lib\\site-packages\\Pythonwin'],
 'sys.prefix': 'C:\\Users\\Simon\\AppData\\Local\\Programs\\Python\\Python311',
 'sys.version_info': sys.version_info(major=3, minor=11, micro=0, releaselevel='final', serial=0)}

Running in PyCharm:




C:\Users\Simon\AppData\Local\Programs\Python\Python311\python.exe C:\Users\Simon\test.py 
{'os.environ': {'ALLUSERSPROFILE': 'C:\\ProgramData',
                'APPDATA': 'C:\\Users\\Simon\\AppData\\Roaming',
                'COMMONPROGRAMFILES': 'C:\\Program Files\\Common Files',
                'COMMONPROGRAMFILES(X86)': 'C:\\Program Files (x86)\\Common '
                                           'Files',
                'COMMONPROGRAMW6432': 'C:\\Program Files\\Common Files',
                'COMPUTERNAME': 'LAPTOP-12NBBS2N',
                'COMSPEC': 'C:\\Windows\\system32\\cmd.exe',
                'DRIVERDATA': 'C:\\Windows\\System32\\Drivers\\DriverData',
                'HOMEDRIVE': 'C:',
                'HOMEPATH': ['\\Users\\Simon'],
                'IDEA_INITIAL_DIRECTORY': 'C:\\Program '
                                          'Files\\JetBrains\\PyCharm Community '
                                          'Edition 2022.3\\bin',
                'LOCALAPPDATA': 'C:\\Users\\Simon\\AppData\\Local',
                'LOGONSERVER': '\\\\LAPTOP-12NBBS2N',
                'NUMBER_OF_PROCESSORS': '12',
                'ONEDRIVE': 'C:\\Users\\Simon\\OneDrive',
                'ONEDRIVECONSUMER': 'C:\\Users\\Simon\\OneDrive',
                'OS': 'Windows_NT',
                'PATH': ['C:\\Windows\\system32',
                         'C:\\Windows',
                         'C:\\Windows\\System32\\Wbem',
                         'C:\\Windows\\System32\\WindowsPowerShell\\v1.0\\',
                         'C:\\Windows\\System32\\OpenSSH\\',
                         'C:\\Program Files\\dotnet\\',
                         'C:\\Users\\Simon\\AppData\\Local\\Programs\\Python\\Python311',
                         'C:\\Windows\\system32',
                         'C:\\Windows',
                         'C:\\Windows\\System32\\Wbem',
                         'C:\\Windows\\System32\\WindowsPowerShell\\v1.0\\',
                         'C:\\Windows\\System32\\OpenSSH\\',
                         'C:\\Program Files\\dotnet\\',
                         'C:\\Users\\Simon\\AppData\\Local\\Microsoft\\WindowsApps',
                         'C:\\Users\\Simon\\AppData\\Local\\Programs\\Python\\Python311\\Scripts',
                         'C:\\Program Files\\PostgreSQL\\13\\bin',
                         ''],
                'PATHEXT': ['.COM',
                            '.EXE',
                            '.BAT',
                            '.CMD',
                            '.VBS',
                            '.VBE',
                            '.JS',
                            '.JSE',
                            '.WSF',
                            '.WSH',
                            '.MSC'],
                'PROCESSOR_ARCHITECTURE': 'AMD64',
                'PROCESSOR_IDENTIFIER': 'AMD64 Family 23 Model 96 Stepping 1, '
                                        'AuthenticAMD',
                'PROCESSOR_LEVEL': '23',
                'PROCESSOR_REVISION': '6001',
                'PROGRAMDATA': 'C:\\ProgramData',
                'PROGRAMFILES': 'C:\\Program Files',
                'PROGRAMFILES(X86)': 'C:\\Program Files (x86)',
                'PROGRAMW6432': 'C:\\Program Files',
                'PSMODULEPATH': ['C:\\Program '
                                 'Files\\WindowsPowerShell\\Modules',
                                 'C:\\Windows\\system32\\WindowsPowerShell\\v1.0\\Modules'],
                'PUBLIC': 'C:\\Users\\Public',
                'PYCHARM_HOSTED': '1',
                'PYTHONIOENCODING': 'UTF-8',
                'PYTHONPATH': ['C:\\Users\\Simon\\OneDrive\\01 Data '
                               'Partition\\04 Programmering\\04 Python '
                               'Programmering\\PycharmProjects\\SR-Polygon'],
                'PYTHONUNBUFFERED': '1',
                'SESSIONNAME': 'Console',
                'SYSTEMDRIVE': 'C:',
                'SYSTEMROOT': 'C:\\Windows',
                'TEMP': 'C:\\Users\\Simon\\AppData\\Local\\Temp',
                'TMP': 'C:\\Users\\Simon\\AppData\\Local\\Temp',
                'USERDOMAIN': 'LAPTOP-12NBBS2N',
                'USERDOMAIN_ROAMINGPROFILE': 'LAPTOP-12NBBS2N',
                'USERNAME': 'Simon',
                'USERPROFILE': 'C:\\Users\\Simon',
                'WINDIR': 'C:\\Windows'},
 'pkg_resources.working_set': [click 8.1.3 (c:\users\simon\appdata\roaming\python\python311\site-packages),
                               dash-table 5.0.0 (c:\users\simon\appdata\roaming\python\python311\site-packages),
                               dash 2.11.1 (c:\users\simon\appdata\roaming\python\python311\site-packages),
                               Flask 2.2.3 (c:\users\simon\appdata\roaming\python\python311\site-packages),
                               Werkzeug 2.2.3 (c:\users\simon\appdata\roaming\python\python311\site-packages),
                               itsdangerous 2.1.2 (c:\users\simon\appdata\roaming\python\python311\site-packages),
                               dash-core-components 2.0.0 (c:\users\simon\appdata\roaming\python\python311\site-packages),
                               dash-html-components 2.0.0 (c:\users\simon\appdata\roaming\python\python311\site-packages),
                               xyzservices 2023.5.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               certifi 2022.12.7 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pytz 2022.6 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pywin32 305 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               setuptools 65.5.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pyzmq 24.0.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pip 23.2.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               attrs 22.1.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               argon2-cffi 21.3.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               packaging 21.3 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               argon2-cffi-bindings 21.2.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               PyQt6-sip 13.4.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               websockets 10.4 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               Pillow 9.4.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               mss 9.0.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               ipython 8.7.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               tenacity 8.1.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               ipywidgets 8.0.4 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               jupyter-client 7.4.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               nbconvert 7.2.5 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pytest 7.2.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               ipykernel 6.23.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               notebook 6.5.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               jupyter-console 6.5.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               PyQt6 6.4.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               PyQt6-Qt6 6.4.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               tornado 6.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               PyYAML 6.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               plotly 5.11.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               psutil 5.9.4 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               nbformat 5.7.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               traitlets 5.6.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               zope.interface 5.5.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               qtconsole 5.4.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               decorator 5.1.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               jupyter-core 5.1.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               bleach 5.0.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               DateTime 5.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               tqdm 4.65.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               fonttools 4.38.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               jsonschema 4.17.3 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               beautifulsoup4 4.11.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               lxml 4.9.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               typing-extensions 4.4.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               exchange-calendars 4.2.8 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pandas-market-calendars 4.1.4 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               widgetsnbextension 4.0.5 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               matplotlib 3.7.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               anyio 3.6.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               Markdown 3.4.3 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               idna 3.4 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               Jinja2 3.1.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               bokeh 3.1.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pyscreenshot 3.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               prompt-toolkit 3.0.33 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               openpyxl 3.0.10 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pyparsing 3.0.9 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               jupyterlab-widgets 3.0.5 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               colorcet 3.0.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               requests 2.28.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               jupyterlab-server 2.22.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pycparser 2.21 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               fastjsonschema 2.16.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               Pygments 2.13.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               Babel 2.12.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               psycopg2 2.9.5 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               python-dateutil 2.8.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               platformdirs 2.5.4 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               soupsieve 2.3.2.post1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               QtPy 2.3.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pyviz-comms 2.2.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               asttokens 2.2.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               markdown-it-py 2.2.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pyluach 2.2.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               snakeviz 2.2.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               MarkupSafe 2.1.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               charset-normalizer 2.1.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pywinpty 2.0.9 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               mistune 2.0.4 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               greenlet 2.0.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               linkify-it-py 2.0.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               iniconfig 2.0.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               urllib3 1.26.13 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               numpy 1.23.5 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               jupyter-server 1.23.3 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               holoviews 1.16.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               six 1.16.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               cffi 1.15.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               param 1.13.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               scipy 1.10.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               finplot 1.9.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pyperclip 1.8.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               ansi2html 1.8.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               Send2Trash 1.8.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pynput 1.7.6 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               debugpy 1.6.7 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               nest-asyncio 1.5.6 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pandas 1.5.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pandocfilters 1.5.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               rfc3986 1.5.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               SQLAlchemy 1.4.46 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               kiwisolver 1.4.4 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               websocket-client 1.4.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               dash-bootstrap-components 1.4.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               retrying 1.3.4 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               sniffio 1.3.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               tinycss2 1.2.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               executing 1.2.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               chart-studio 1.1.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               EasyProcess 1.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               entrypoint2 1.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               et-xmlfile 1.1.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               polygon 1.1.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               PyMsgBox 1.0.9 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pytweening 1.0.7 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               contourpy 1.0.7 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               panel 1.0.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               uc-micro-py 1.0.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               jupyter 1.0.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pluggy 1.0.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               httpx 0.23.3 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pyrsistent 0.19.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               jedi 0.18.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               cufflinks 0.17.3 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               terminado 0.17.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               httpcore 0.16.3 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               prometheus-client 0.15.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               h11 0.14.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               statsmodels 0.13.5 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pyqtgraph 0.13.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               seaborn 0.12.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               toolz 0.12.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               cycler 0.11.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               PyAutoGUI 0.9.54 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               json5 0.9.14 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               ipympl 0.9.3 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               tabulate 0.9.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               hvplot 0.8.3 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               parso 0.8.3 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pickleshare 0.7.5 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               nbclient 0.7.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               defusedxml 0.7.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               mouse 0.7.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               jupyter-contrib-nbextensions 0.7.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               stack-data 0.6.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               jupyter-nbextensions-configurator 0.6.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               patsy 0.5.3 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               webencodings 0.5.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pyct 0.5.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               nbclassic 0.4.8 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               colorama 0.4.6 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               jupyter-contrib-core 0.4.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               entrypoints 0.4 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               voila 0.4.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pandas-ta 0.3.14b0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               mdit-py-plugins 0.3.5 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pyinput 0.3.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               korean-lunar-calendar 0.3.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               colorlover 0.3.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               wcwidth 0.2.5 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               jupyterlab-pygments 0.2.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               notebook-shim 0.2.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               pure-eval 0.2.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               kaleido 0.2.1 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               PyRect 0.2.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               backcall 0.2.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               ipython-genutils 0.2.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               jupyter-highlight-selected-word 0.2.0 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               PyScreeze 0.1.29 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               matplotlib-inline 0.1.6 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               MouseInfo 0.1.3 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               comm 0.1.3 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               mdurl 0.1.2 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages),
                               PyGetWindow 0.0.9 (c:\users\simon\appdata\local\programs\python\python311\lib\site-packages)],
 'sys.path': ['C:\\Users\\Simon',
              'C:\\Users\\Simon\\OneDrive\\01 Data Partition\\04 '
              'Programmering\\04 Python '
              'Programmering\\PycharmProjects\\SR-Polygon',
              'C:\\Users\\Simon\\AppData\\Local\\Programs\\Python\\Python311\\python311.zip',
              'C:\\Users\\Simon\\AppData\\Local\\Programs\\Python\\Python311\\Lib',
              'C:\\Users\\Simon\\AppData\\Local\\Programs\\Python\\Python311\\DLLs',
              'C:\\Users\\Simon\\AppData\\Roaming\\Python\\Python311\\site-packages',
              'C:\\Users\\Simon\\AppData\\Local\\Programs\\Python\\Python311',
              'C:\\Users\\Simon\\AppData\\Local\\Programs\\Python\\Python311\\Lib\\site-packages',
              'C:\\Users\\Simon\\AppData\\Local\\Programs\\Python\\Python311\\Lib\\site-packages\\win32',
              'C:\\Users\\Simon\\AppData\\Local\\Programs\\Python\\Python311\\Lib\\site-packages\\win32\\lib',
              'C:\\Users\\Simon\\AppData\\Local\\Programs\\Python\\Python311\\Lib\\site-packages\\Pythonwin'],
 'sys.prefix': 'C:\\Users\\Simon\\AppData\\Local\\Programs\\Python\\Python311',
 'sys.version_info': sys.version_info(major=3, minor=11, micro=0, releaselevel='final', serial=0)}

Process finished with exit code 0



0

Hmm, interesting, so the package is seen in both cases.
Could you create a new project with a new virtual environment, install dash, and try importing it there?
Does it work?

1

Good idea. I had not tried that, but I did just now.

Turns out in the new project it works both via the system interpreter (3.11) and via venv!

The most surprising part to me is that from the start I tried running the file both via both venv and the system interpreter - so the latter works in one project but not in another!

 

0

We can try a few more things:

1. Remove the run configuration (Run | Edit Configurations...). Then right-click the file and choose Run from the context menu.

2. If the issue remains, try removing the .idea folder of the problematic project. It contains project-specific settings.

0

I have done a few reboots since and of course the above mentioned things.

It turns out today that dash runs fine from both files/projects - where as the other day it would only run from the new project.

Thanks again for your inputs. I'm not exactly sure what to take away from all of this. At least it's a reminder that sometimes it can help to restart Pycharm and/or Windows, and that copying the code to a new project can also be a fix.

0

Please sign in to leave a comment.