After updating IntelliJ IDEA 2024.1 EAP to build version 241.14024.14, a problem with launching appeared (Linux Mint 21.3)


After updating IntelliJ IDEA 2024.1 EAP to build version 241.14024.14, a problem with launching appeared:
IDE does not open existing projects. After trying, it just hangs with the spinner sign. 

In this case, the process hangs in the top, but nothing happens for a long time.

UPD: I had a similar problem in versions 2023.3.x. So I stayed on version 2023.2.5 and avoided using versions 2023.3.x. After the appearance of the 2024.1 EAP, it worked well for me until the latest update.


Could you please share a screenshot or screen recording that shows the hanging issue? It would help us understand better at which point it hangs, during startup, after IDE started etc. Also, please share your IDE logs directory compressed. You can upload all the information here:, just provide the uploaded file ID. Thank you.


Hi Ivan Pajic, thanks for your involvement.
Here are the files you asked for:
Upload id: 2024_03_04_UFh7y6qZsWr4PWJj6HQfAx (files: log.tar.gz, Peek 2024-03-04 22-13.gif) 


Thank you for the logs. There is an issue with similar thread dump as in your case: It looks like the GitHub Copilot version causes the freeze. Could you try disabling GitHub Copilot plugin or rollback the version?


I have created a bug report for you here:
As a workaround, please open the welcome screen, press `Ctrl+Shift+A` to open the Find Action dialog, enter `Invalidate Caches`, press it, click the `Invalidate and Restart` button to see if it helps.

I removed the GitHub Copilot plugin completely, but it didn't help. I also tried to remove other plugins one by one and this also had no effect.

Could you please open the IDE's welcome screen, press "Ctrl+Shift+A" to open the Find Action dialog, enter "Invalidate Caches", press it, click the `Invalidate and Restart` button to see if it helps?

Unfortunately, nothing that was suggested helped me. 
But there is a new observation: the same problem occurs when updating the version. 
The configuration phase takes a very long time, just like launching the IDE.

The version 2024.1 Beta has the same problem, while version 2023.2.6 works fine.


Ilya Kovalkov Try to close the IDE, remove `~/.cache/JetBrains/IntelliJIdea2024.1` to see if it works.

If it doesn't help, can you please share your IDE logs directory compressed, upload all the information here,, share us the upload id again? Thanks.


Please sign in to leave a comment.