Full line code completion is disabled with Copilot installed but completions disabled

Answered

I quite like the full line completion provided by IntelliJ, more so than the one by Copilot. But now that the chat feature is available I'm trying out Copilot again. With the plugin enabled IntelliJ tells me that “to enable full line completion, you will need to disable [Copilot] first”. But I disabled “Automatically show completions” in the Copilot settings so now I don't have any completion candidates shown to me.

I think IntelliJ should be able to detect that if possible and enable the completions if disabled in Copilot.

0
3 comments

Hello, Simon Stratmann.

I think IntelliJ should be able to detect that if possible and enable the completions if disabled in Copilot.

It is possible, but the solution could be too complex and unstable because of the current GitHub Copilot implementation - it seems the developers didn't use our API to write the plugin's code. I have already discussed this problem with one of the responsible developers, and it is not likely we consider implementing this solution in the current situation. However, if the GitHub Copilot developer team considers using our API for the plugin development, it could be much easier for our plugin to recognize the Copilot completion option is disabled. 

1

I wonder if there's a way to repackage the GitHub Copilot plugin so that IntelliJ doesn't try to recognize it. Yes it would be unstable and unsupported and of course frowned upon by JetBrains. But if I accept the risk, this is important enough for me to try it.

0

This will cause various issues. Please wait until the plug-in migrates to our API.

1

Please sign in to leave a comment.