Pycharm built-in preview won't auto-reload pages

Hello all,

I recently started using Pycharm Professional 2023.3, and updated to 2024.1 today. I've had this issue from the beginning and the update did not solve it.

On my end, Pycharm won't auto-reload pages displayed in the built-in preview, even though I repeatedly changed the built-in preview settings (to have the page reload on save, on change… etc, made sure it was using my default browser to render it…). Be it included in Pycharm, or opened directly in my browser (Firefox or Edge), the page never reloads on its own, even though it's supposed to (the URL does display “RELOAD_ON_SAVE” or “RELOAD_ON_CHANGE”, correctly according to what I set). In my browsers, I need to reload manually every time.

I've had no trouble with the Webstorm built-in preview, on the same project, or on blank projects I created to figure out if it was linked to mine or not. CLion's built-in preview also works fine on all projects. This situation seems linked to Pycharm. I tried resetting all IDE settings for Pycharm, to no avail.

I need to work with Python, front-end web tools (HTML/CSS/JS), and R, so Pycharm best suits my needs. I would love to use it for all of my work, but no built-in preview makes it difficult. What could I be missing here? Thanks for reading!

0
2 comments

Hi Stan . It looks like a known issue, unfortunately: https://youtrack.jetbrains.com/issue/PY-70515

Please vote for it and feel free to comment. See https://intellij-support.jetbrains.com/hc/en-us/articles/207241135-How-to-follow-YouTrack-issues-and-receive-notifications if you are not familiar with YouTrack.
 

1

Hey Mikhail, thank you for reaching out to me! I'd looked up the issue online before, but hadn't found this YouTrack page.

For the time being, disabling the Jupyter plugin did fix the problem. I voted for it on YouTrack, and commented accordingly. Although I know it's not ideal, I'm very happy and excited to have found a fix! Have a nice day!

0

Please sign in to leave a comment.