Update classes and resources not working with Resin-3.1.13

Answered

Hello, I'm quite a greenhorn in IntelliJ, just immigrated to it from Eclipse a few days ago.

The problem I have is that the server must be manually restarted each time changes are made to resources like html or JSP, Update classes and resources is not working in the least, and what's weird to me is Redeploy only made a partial project being reflected in webapps directory of the resin, however any changes I made is correctly updating in the artifact output directory, please help me.

technical information.

  • IntelliJ version is 2016.1 x86
  • JDK 1.8.0_60-b27
  • Resin-3.1.13

Thanks in advance.

 

4 comments
Comment actions Permalink

Make sure the artifact is Exploded, see also https://www.jetbrains.com/idea/help/updating-applications-on-application-servers.html.

See if the issue persists with the latest IDEA version.

If you can't find the problem, please submit a ticket to support with a sample project and the exact steps to reproduce the problem.

Note that IDEA instructs Resin to load the web application from the artifact output folder.

0
Comment actions Permalink

Thank you for your quick response, I've followed the steps in the link, but ended with no luck.

FYI, the artifact is packaged as exploded war, action specified on frame deactivation is Update classes and resources, and surprisingly resources changed are immediately copied to the artifact output folder [verified], however, the same but outdated resources in the deployed directory, let's say "webapps", remain intact, so I wonder if there's a way I could explicitly instruct Resin to load the latest file from the artifact output folder?

0
Comment actions Permalink

The way it works is that IDEA updates the artifact output folder and instructs the app server to load the web application from that folder instead of webapps folder. Normally webapps folder is empty.

If you are using customized startup scripts/VM options, they may override IDE supplied options and your app server will continue to load the web apps from the default folder instead of using the customized artifact output location. In this case you can change the artifact configuration so that it produces the files directly under webapps folder of your app server.

0
Comment actions Permalink

I've managed to solve the problem by

  1. Open Run/Debug Configuration
  2. Select Deployment tab -> choose resin.xml from Deployment Method drop-down box.
  3. Apply, and OK.

I can't solve it alone without your help, truly learn a lot about the underlying mechanism of IntelliJ from you, thank you very much!

0

Please sign in to leave a comment.