IntelliJ 2016.2.4 Extremely slow while typing

Answered

Since switching from IntelliJ 15 to 2016.2.4, the performance is really bad. Sometimes there is no response for multiple seconds, while typing something.

Edit: It is especially laggy when renaming variables.

I disabled a multitude of third-party plugins and the performance was still as bad.

Also, I enabled CPU profiling, typed for a moment and uploaded it here: https://cloud.jmnw.me/s/lGOCQaRZqLAz834 .

This is the version info from the IntelliJ about screen:
IntelliJ IDEA 2016.2.4
Build #IU-162.2032.8, built on September 9, 2016
JRE: 1.8.0_101-b13 amd64
JVM: Java HotSpot(TM) 64-Bit Server VM by Oracle Corporation

I am on Ubuntu 14.04.5 LTS.

Thanks!

3 comments
Comment actions Permalink

What VCS do you use? Does it help if you disable it for a moment and restart IDEA? http://www.jetbrains.com/idea/webhelp/enabling-and-disabling-plugins.html

0
Comment actions Permalink

Please also try running with JetBrains Runtime instead of Oracle JDK: https://intellij-support.jetbrains.com/hc/articles/206544879

0
Comment actions Permalink

Seems like the JetBrains Runtime helped a bit, it was still set to the Oracle JDK because I imported the old IntelliJ config. If I notice more performance issues, I will post again.

Thanks!

0

Please sign in to leave a comment.