Solved: Trouble setting up Oracle connections using tnsnames.ora

I can't seem to find any information on setting up a working oracle connection using a tnsnames file.  I am also unclear on what the TNSADMIN is used for, but did find a reference online where someone pointed to sqldeveloper, seemed odd.

I just need:

1. Where does DG look for the tnsnames.ora file

2. Do I need to provide a value for the TNSADMIN field and if so, what?

Thanks!

 

SOLUTION:

The TNSADMIN field should probably be renamed TNSNAMES... If you put the path to your tnsnames.ora file here, all works perfectly.  

9 comments
Comment actions Permalink

I should add, that I have no problem setting up and getting a working connection using SQLDeveloper on the same machine, if that helps provide context!

0
Comment actions Permalink

Solved my own problem - Turns out that the TNSADMIN field is where you provide the PATH to your tnsnames.ora file.  Once I did that it worked perfectly...  I was just confused - would sure be helpful if they simply provided a bit of contextual information for the field to better specify what was supposed to go there.

0
Comment actions Permalink

Hi,

Thank you for your feedback.

0
Comment actions Permalink

I've just installed DG and would like to connect using tnsnames file.

Can you add instructions on how to do this?

Thanks

0
Comment actions Permalink

Vasily...anyone? I'm about to uninstall

1
Comment actions Permalink

Hi,

The best way to create a new thread since this one has solved in the header.

Could you describe the problem?

Thank you.

0
Comment actions Permalink

Ok no problem I've just installed and want to connect so just want to point to my tnsnames

I've got the TNS_ADMIN env variable created

Do I add it here?

0
Comment actions Permalink

Hi,

You need to create new data source and choose TNS:


and provide propor values for TNSADMIN, TNS name, user, password and etc.


Thank you.

0
Comment actions Permalink

Hi Guys,

My Settings look like this

I have helped in something

0

Please sign in to leave a comment.